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Module 1. Introduction
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In This Module

• New Features
• EasyEXPERT
• To Perform Easy Application Test
• User Interface
• Modular Mainframe
• SCUU/GSWU
• ASU
• B2200 Switch Control
• Desktop EasyEXPERT
• 415x Setup File Converter

Note:
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Comprehensive 
application 

library

Revolutionary 
EasyEXPERT 
environment

Semi-auto 
prober control

10 Slots 
variable module 

configuration

SCUU/GSWU 
for IV/CV 

combination

Touch-screen 
w/optional 

USB keyboard 
& mouse

Agilent B1500A Semiconductor Device Analyzer

B2200 switch 
control

415x setup file 
converter

ASU for 
100 aA 

The B1500A has many exciting new features and capabilities.
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New Features
• EasyEXPERT software

• Application test environment (> 150 algorithms)

• Classic test environment – 415x like setup

• Quick test environment – multiple test execution

• Semi-auto prober control and B2200 switch control

• Modular mainframe 

• MFCMU for C-V sweep

• HPSMU, HRSMU, MPSMU for I/V sweep/sampling

• SMU CMU Unify Unit (SCUU)/Guard Switch Unit (GSWU)

• switching effortlessly between  IV and CV measurement

• Atto Sense/Switch Unit (ASU)

• 100 aA level low current measurement

• Touch-screen, knob, and softkeys

• optional USB keyboard, mouse, and stylus pen

The EasyEXPERT software 
•Task-oriented, “top-down” approach to device characterization

•Multiple test execution

•Automatic measurement, auto-analysis functions

•Test sequencing without programming

Application Library (>150 algorithms)
•Categorized and organized 
•Easy-to-use
415x setup file converter program
Versatile Modular Mainframe
•Flexible & Expandable   (10 slots)
•Multiple SMU types
•Atto-sense and Switch Unit (ASU)
•Multi-Frequency CMU
•SMU CMU Unify Unit for IV/CV Probing
•4.2 Amp Ground Unit
Convenient User Interface 
•Touch screen operation (with optional stylus pen)
•Contextual softkeys & knob control
•Optional USB keyboard & mouse
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EasyEXPERT

MeasurementMeasurement
resourcesresources

V/I on terminalsV/I on terminals

Device parametersDevice parameters

Device typeDevice type

Technology Technology 
classificationsclassifications

Vth Idon Idoff gm Igleak Rg

Vg Vd Vs Vsub
Ig Id Is Isub

SMU1 SMU2 SMU3 SMU4

Mode

V

I

Mode

V

I

Mode

V

I

Mode

V

I

GaAs WLR
Nano-
tech

CMU

Mode

AC V

range

MOS
FET

Res. Cap.
Bipolar

Tr

CMOS

Instead of setting up the instrument hardware, the EasyEXPERT software focuses on the real task 
at hand for the engineer ---device characterization.  All that you need to do is to connect the 
instrument to the device terminals as shown in the EasyEXPERT test parameters area.

The EasyEXPERT software also provides the classic test mode that allows the 4155/4156 like 
measurement setup operation.
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To Perform Easy Application Test

List of test record

Step 1: Click Application Test tab.

Step 2: Select one or more technology categories, and select a desired test from the list of tests 
associated with the selected technology categories.

Step 3: Change the setup parameters (Device parameters and Test parameters) if you want.

Step 4: Connect DUT, and click the Start button.  The B1500A starts the selected test.

Step 5: Analyze the measurement result data displayed on the Data Display window automatically 
opened after the test.

The measurement result record is automatically stored in the internal hard disk drive when the 
Auto Recode mode is ON.
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User Interface

• Touch panel
• Stylus pen (option)

• Rotary knob
• Softkeys
• USB keyboard (option)
• USB mouse (option)
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Modular Mainframe
10 module slots

B1510A HPSMU

GNDU: 4.2 A

N1301A-100 SCUU 
N1301A-200 GSWU

E5288A ASU

B1517A HRSMU

B1511A MPSMU

B1520A CMU

The following modules and accessories are available for the B1500A:

•B1520A CMU: 1 kHz to 5 MHz CV capability (1 slot)

•B1511A MPSMU: 100 mA/100 V force capability,  10 fA/0.5 mV measurement resolution (1 slot)

•B1517A HRSMU: 100 mA/100 V force capability,  1 fA/0.5 mV measurement resolution (1 slot)

•B1510A HPSMU: 1 A/200 V force capability,      10 fA/2 mV measurement resolution (2 slots)

•N1301A-100/102: SMU CMU unify unit (SCUU) & cable assembly

•N1301A-200/201/202: Guard switch unit (GSWU) & cable assembly

•E5288A ASU: 0.1 fA/0.5 mV measurement resolution with support for IV/CV switching

The ASU  (Atto sense/switch unit) can be used with the HRSMU calibrated with it.

The SCUU can be used with the CMU (slot N), SMU (slot N-1), and SMU (slot N-2).

The GSWU can be used with the SCUU.
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SCUU

CMU

SMU CMU
Unify Unit

(SCUU)

SCUU cable

Simple direct connection
between SMU/CMU and 
manipulators (positioners)

SMU

SMU

GSWU

Force1 or 
CMUH

Force2 
or 
CMUL

Source1

Source2

You have a very hard time switching between CV and IV measurements (you may actually devote 
separate probe stations to CV and IV just to avoid having to change cables).  In addition, great 
care has to be taken when cabling to a capacitance meter to insure that all of the capacitance 
measurements are properly compensated.  The SCUU removes all of these worries and makes 
connection simple and easy.  In addition, the B1500A software automatically takes care of the 
multiplexing based upon the type of algorithm selected from the front panel.

To install the SCUU near the manipulators/positioners, use the N1301A-102 SCUU cable. 

To realize accurate capacitance measurement, use the N1301A-200/201/202 GSWU & cable. 
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GSWU

GSWU

SCUU

The GSWU must be connected to the outer conductors of the manipulators/positioners 
connected to the Force1/CMUH and Force2/CMUL connectors of the SCUU. And the GSWU 
control cable must be connected between the GSWU and the SCUU.

When the SMU paths are available for the manipulators/positioners, the GSWU opens between 
the outer conductors. However, when the MFCMU paths are available, the GSWU connects them 
together to make the return path of measurement current. This will reduce the signal path 
impedance. And this is effective for the accurate capacitance measurement.

By using the EasyEXPERT software, cable length between the CMU and the SCUU is 
automatically detected, and the GSWU switch control is automatically performed.  Also, 
capacitance error compensation is also automatically performed if the compensation data are 
available.

The GSWU is effective for
•reducing the residual inductance of the measurement cable
•stabilizing the residual inductance when measurement cable distance is changed (moved)
It’s roughly 1/10 to 1/30 when used with two 80 cm cable.

Note:

When the SMU paths are available for the manipulators/positioners, the outer conductors must 
be open because they must be connected to the SMU guard terminals that must be always open.
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ASU
• 100 aA level sensing
• Channel switching

• C measurements
• PG for charge pumping

HRSMU Force
HRSMU control

C meter Hcur

ASU2

ASU1

HRSMU Force
HRSMU control

C meter Hpot

C meter Lcur
C meter Lpot

Hcur/Hpot or Force

Lcur/Lpot or
Force

Source

Source

Return path for C meter

The high-resolution SMU (HRSMU) has an innate 1 fA & 0.5 mV measurement resolution. The 
optional ASU extends the HRSMU measurement resolution to 0.1 fA.

The ASU has another feature, built-in switching capability. It can switch between the SMU and an 
auxiliary input (AUX input, two BNC). 

If the Agilent 4284A LCR meter is connected to the AUX inputs, the ASU can switch between the 
low current and CV measurements. Then connect a wire between the CMU return terminals of 
ASUs to make the return path of measurement current.  This is effective for accurate capacitance 
measurement.  However, you need to perform capacitance compensation by yourself. 
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B2200 Switch Control

• Allows use of a probe card to facilitate probing of standardized device 
modules (usually 24-pin configuration)

• Enables easy multiplexing between the triaxial outputs of SMUs and 
the coaxial outputs of other (BNC-based) instruments and modules

Switching Matrix

Wafer Prober

Device Analyzer

8

6

12 - 48

Triaxial 
(SMU) Triaxial

Coaxial 
(CMU, other)

GPIB cable GPIB cable

Agilent B2200A/B2201A switching matrix can be controlled by B1500A/EasyEXPERT via GPIB.  
EasyEXPERT provides the Switching Matrix Operation Panel for interactive control of B2200 
independent from the test execution mode of B1500.  And switch setup can be saved to a classic 
test setup data.  In the classic test, the switch setup is sent to B2200 when a measurement start 
button is clicked. 

B1500A/EasyEXPERT also provides the semi-auto prober control script.  The semi-auto prober 
can be controlled without programming.  The prober control script supports the die move 
operation by using the following first three procedures in the repeat measurement setup and adds 
the subsite move operation by using the Subsite procedure in the quick test setup. 

Prober control script:

•Start procedure

•Iteration procedure

•Final procedure

•Subsite procedure
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Desktop EasyEXPERT Software

The Desktop EasyEXPERT software provides the following additional advantages to the B1500A, 
allowing you to minimize the amount of offline tasks performed on B1500A and increase the 
working ratio for measurements.

•Allows B1500A to be controlled from an external computer via GPIB while online.

•Allows test setup to be created on an external computer while offline.

•Allows data analysis to be performed on an external computer while offline.

To start Desktop EasyEXPERT, see Module 8.
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415x Setup File Converter

4155/4156 setup file
(file extension: MES)

B1500A setup file
(file extension: XTS)

Execution example:
C:\Mydata>SetupFileConverter.exe setup1.mes
C:\Mydata>SetupFileConverter.exe *.mes

SetupFileConverter.exe Import

To control the B1500A, you can reuse the 4155/4156 setup file (.MES file) by converting the .MES 
file to the EasyEXPERT setup file (.XTS file).  The file conversion can be done by the 
SetupFileConverter.exe file.  To execute the file conversion, see Module 8.
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Module 2. Performing Easy Tests
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In This Module

• To Turn on/off B1500A
• To Launch EasyEXPERT
• To Specify/Create Workspace
• To Perform Application Test
• To Save/Recall Your Test Setup
• To Export/Import Your Preset Group
• To Export/Import Test Record
• To Perform Quick Test
• To Control B2200 Switching Matrix
• To Manage Data Display Window

This section explains the above tasks.  You will understand how to launch B1500A/EasyEXPERT, 
how to perform application test and quick test, and how to create your test setups and preset 
groups.
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To Turn on/off B1500A

The Standby button works to turn on the B1500A when it is turned off. When the B1500A is 
turned on, the Standby button works to terminate the EasyEXPERT software, Windows, and turn 
off the B1500A.

After the B1500A is turned on, log on Windows.

The default user is Agilent B1500 User with no password.
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To Launch EasyEXPERT

Start EasyEXPERT button/window

Start EasyEXPERT icon

After logging on, click Start EasyEXPERT button to launch the EasyEXPERT software.

If you do not see the Start EasyEXPERT button, double click the Start EasyEXPERT icon to open 
the Start EasyEXPERT window.
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To Specify Workspace

Case 1

Case 2 Case 3

After launching the EasyEXPERT, you will see one of the above screens.

Case 1: If this is the first time to launch the EasyEXPERT

The LCD displays the EasyEXPERT main screen.

Case 2: If the B1500A has one workspace only

Select Yes, and click OK if you use the existing workspace.

The EasyEXPERT main screen is displayed.

Select No, and click Next if you want to create a new workspace.

See next slide.

Case 3: If the B1500A has some workspaces (more than one)

Select workspace you want to use, and click Continue.

The EasyEXPERT main screen is displayed.

If you create workspace, check the Create a new Workspace radio button, and click Continue.

To create a public workspace, check the Allow other users to access this workspace box.  The 
public workspace can be used by all users.

To create a private workspace, delete the check from the Allow other users to access this 
workspace box.

Workspace is the space created in the Agilent B1500A’s internal hard disk drive, and is used to 
store the test setup, measurement result data, and so on.  The workspace can be created and 
allocated for each  user.
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To Create Workspace

1: New workspace name to create

Check this box for
Public workspace

2: New workspace name to rename

1

2

Enter the workspace name and click OK to create/rename the workspace.

If you want to create a public workspace, check the Allow other users to access this workspace
box.

The public workspace can be used by all users.

If you want to create a private workspace, delete the check from the Allow other users to access 
this workspace box.
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Online Help

Online Help is available for the B1500A and EasyEXPERT.  Select Help > Agilent EasyEXPERT
Help menu to display the online help window.  The online help provides the following information.

•Introduction describes overview, front view, rear view, and measurement units of the Agilent 
B1500A.

•Using EasyEXPERT provides the reference information of the Agilent EasyEXPERT software.

•Function Details explains the measurement functions of the B1500A with EasyEXPERT.

•Built-in Programming Tool provides the reference information of the built-in function, read out 
functions, and script programming statements.

•If You Have a Problem describes the problem solving information, the B1500A system 
maintenance information, and the error messages.
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Application Test Description

To know about the application test, click the ( i ) icon.  This icon displays the message box that 
explains the application test definition.  This function will help you to know what is and how to 
use the application test.
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Typical Value Selection

Right clicking 
this field 
displays the 
menu.

The values are 
defined as 
typical values 
in the Test 
Definition.

You do not need to hit the keyboard.

When you set a test condition of application test, you do not need to use keyboard.  You can 
select the value from the typical values as shown below.

•Click the entry field of a setup parameter by using the touch screen or the mouse.  This displays 
the typical values for the specified parameter on the softkeys.

•Select one of the softkeys.

Also you can use the following manner.

•Point the entry field of a setup parameter by using the mouse. 

•Right click the mouse to display the popup menu.

•Click the Select menu to display the typical values for the specified parameter.

•Select one from the typical values.

Note:
The typical values are defined in the test definition.  And you can change the values by using the 
Define typical values window opened by clicking the Typical Values button on the Test 
Specification screen of the Test Definition window.  For the Test Definition window, see Module 
4.
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Screen Keyboard

When you need to enter numeric characters in an entry field, you will see the icon at the right 
side of the entry field.  This icon opens the Numeric KeyPad.  You can use this screen keypad 
instead of the USB keyboard.

When you need to enter alphabetic characters in an entry field, you will see the icon at the right 
side of the entry field.  This icon opens the On Screen Keyboard.  You can use this screen 
keyboard instead of the USB keyboard.
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To Perform Application Test

Test Record List area

Step 1: Click Application Test tab.

Step 2: Select one or more technology categories, and select a desired test from the list of tests 
associated with the selected technology categories.

Step 3: Change the setup parameters (Device parameters and Test parameters) if you want.

Step 4: Connect DUT, and click the Single button.  The B1500A starts the selected test.
After the test, the test result data is displayed on the Data Display window.  And the Test Result 
Editor is also displayed on the lower left area of the B1500 screen.  See the next page.

Step 5: Analyze the measurement result data.

The measurement result record is automatically stored in the internal hard disk drive. 
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Test Result Editor

• Save/Delete

• ! Important

• # Valid

• ? Questionable

• Remarks

• OK

The Test Result Editor provides the following GUI to set a flag and remarks to the test result 
record.  Set the flag and remarks to the test record.
•Save button and Delete button
Divides test records into groups, Save and Delete.
Test records in Save-group are always listed in the lower area of the EasyEXPERT main screen.
Test records in Delete-group can be listed when Results > Filter > Show Deleted Data is checked.
•Flags buttons
The following buttons are available.  You can set one of the following flags.
•Important ! Button
Sets the important flag (!) to the test result record.
•Valid # button
Sets the valid flag (#) to the test result record.
•Questionable ? Button
Sets the questionable flag (?) to the test result record.
•Remarks field
You can enter characters into this field.  The characters will be recorded as the Remarks value of 
the test result record.
•OK button
Applies the setup on the Test Result Editor, and closes this dialog box.
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Test Record List Area
Flag Setup Name

Vth gmMax
Vth gmMax

Vth gmMax
Vth gmMax

ID-VD1
ID-VD1
ID-VD1
ID-VD1
Vth gmMax

Vth gmMax
ID-VD1

#
#
?
?

!
!

A
A
S
S
A
A
S

*Flag Setup Name
Vth gmMax

Vth gmMax
ID-VD1
ID-VD1
Vth gmMax

Vth gmMax
ID-VD1

#
#

!
!

…
…
…

*

Flag Setup Name
Vth gmMax
ID-VD1
ID-VD1
Vth gmMax
ID-VD1

#

!

…
…

*

Results > Filter > Show Deleted Data

Show All Append Data

Expand Application Test Results

The test result records are listed in the test record list area. The area also lists the following data.
•Append measurement data marked with …
•Deleted data marked with * if Results > Filter > Show Deleted Data is checked
•Test name defined in the application test definition if Results > Filter > Expand Application Test 
Results is checked
If Results > Filter > Show All Append Data is checked, all append data will be listed and the 
symbol will be changed to A for the data obtained by the Append measurement or S for the data 
obtained by the Single measurement.
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Single/Append/Repeat measurement
Single
RepeatAppend

The EasyEXPERT provides three execution modes, Single, Append, and Repeat. 

Single button triggers a single measurement.

Append button triggers an append measurement. The measurement results will be appended to 
the Data Display window that shows the previous measurement results. The Data

Display window can have maximum 10 layers for displaying measurement results.

Repeat button opens the Repeat Measurement Setup dialog box used to set the repeat 
measurement condition.  To perform the repeat measurement, see Module 7.

To abort measurement, click Stop button that appears instead of the Single button.



2-15

To Save/Recall Your Test Setup

Preset Group name.
Use this field to select 
preset group.

My Favorite Setup button

The test setups you create or modify MUST be saved in a preset group (My Favorite Setup).

To save the setup, click the Save button.

To recall the setup, click the Recall button.

You can organize the setups by using the My Favorite Setup button. 

To select the available preset group, use the field below the My Favorite Setup button.  In the 
above example, the Demo group is selected and listed in the My Favorite Setup list.

To rename, duplicate, or delete the setups, and to add, rename, duplicate, delete, import, or export 
the preset group, use the function of the My Favorite Setup button menu or the Organize Preset 
Group dialog box shown in the next page.
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To organize preset group for test setup 
My Favorite Setup   button

This dialog box is opened by selecting the Organize Preset Group function of the My Favorite 
Setup button menu, and is used to organize the preset group.
•Preset Group List
Lists the preset groups saved in the workspace.  The Add, Rename, Duplicate, Delete, Import, and 
Export buttons are available to organize the preset groups.
•Copy 
Sets the operation of the >> button and the << button. They work as Copy when this check box is 
checked, and as Move when this check box is blank.
•>> 
Copies or moves the preset setup selected in the left Preset Group box to the right Preset Group 
box.
•<< 
Copies or moves the preset setup selected in the right Preset Group box to the left Preset Group 
box.
•Close 
Closes the Organize Preset Group dialog box.
•Preset Group 
Lists the preset setups saved in the preset group.  The Select All, Unselect All, Rename, 
Duplicate, and Delete buttons are available to select or organize the setups saved in the preset 
group.
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To Export/Import Your Preset Group

My Favorite Setup
button

You can export/import your preset group.

To export the present preset group, click the My Favorite Setup button, select Export, and specify 
the folder and the name of the preset group to export. 

To import the preset group, click the My Favorite Setup button, select Import, and specify the 
preset group to import. 
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To Export/Import Test Record

1. Select data record to export, 
and right click.

2. Select Transport Data > 
Export As xxxx.

To export the test result record, specify the data records and select the Transport Data > Export 
As xxxx menu.

You can save the data records as an EasyEXPERT file, a CSV file, a XML spreadsheet file, or a 
XML file created by using the specified XML style sheet.  

You can import the data record exported as the EasyEXPERT file or the XML spreadsheet file.

To import the file, select the Transport Data > Import… Then the Test Result Import dialog box is 
opened.  On the dialog box, select the file to import. 

You can read by using a text editor or a spreadsheet software as shown above.  This example 
reads a test record exported to a CSV file. 
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Exercise 1

Perform Application Test.

1. Open Vth gmMax test definition in the CMOS library.

2. Change the setup (SMU, output value, etc.)

3. Create your preset group, and save your setup. 

4. Connect device (MOSFET).

5. Perform Application Test.

Time to complete: 5 minutes.

Note:
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Device Connection Example

16088-60002 Dual in line package (28 pin)

1 2 3 4 5 6

7 8 9 10 11 12

13 14 15 16 17 18

2019 21 22 23 24

25

27

26

28

14

1528

1

F

G

3
F

G

4
F

G

5
F

G

6
F

G

2
F

G

1
SMU

21
VMU

21
VSU

F

S

GNDU

F
2

F
1

PGU Drain   Gate    Source  Substrate

G
S

D Sub

1      2    3     4

MOSFET: SD214DE

For all class exercises, you need the 28-pin dual in line socket which comes standard with the 
4145 fixture (16058A) or the 4156 fixture (16442A/B).  Either fixture works fine.

With the 16442A/B fixture, note that there are two SMU numbering schemes....3 SMUs with 
force and sense, or six SMUs with force only.   For this class example we will use the six (6) SMU 
scheme.

To mount the MOSFET, the leads must be re-arranged into a straight line as shown.

IMPORTANT:

The MOS FET is highly sensitive to electrostatic damage.  Touching the bare leads will definitely 
destroy the device.  The device comes with a special shorting wire attached.  Bend the leads the 
way you want, insert the device in the socket, and then remove the shorting wire.  The wire has a 
tab.  Just grab the tab and pull straight out.  The wire will spiral out as you pull.
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Setup Example

3. changed

3. changed

3. changed

3. changed

5. created

5. saved

2. selected

Test result data (record) is automatically saved after measurement.

Note:
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Result Example

Note:
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To Perform Quick Test

Softkeys
for single 
measurement

Step 1: Click Quick Test tab.

Step 2: Select the Preset Group.

Step 3: Mark (check) the test setups to be executed while the Quick Test is executed.

Step 4: Connect DUT, and click the Single button.  The B1500A starts the selected tests from top 
to bottom in the list.

After the test, the test result data is displayed on the Data Display window.  And the Test Result 
Editor is also displayed on the lower left area of the B1500 screen.

Step 5: Analyze the measurement result data.

The measurement result record is automatically stored in the internal hard disk drive. 

The softkeys placed right side of the LCD are used to trigger a single measurement of the 
associated test.
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To organize preset group for test setup 
My Favorite Setup banner

This dialog box is opened by selecting the Organize Preset Group function of the My Favorite 
Setup banner menu, and is used to organize the test preset group.
•Preset Group List
Lists the preset groups saved in the workspace.  The Add, Rename, Duplicate, Delete, Import, and 
Export buttons are available to organize the preset groups.
•Copy 
Sets the operation of the >> button and the << button. They work as Copy when this check box is 
checked, and as Move when this check box is blank.
•>> 
Copies or moves the preset setup selected in the left Preset Group box to the right Preset Group 
box.
•<< 
Copies or moves the preset setup selected in the right Preset Group box to the left Preset Group 
box.
•Close 
Closes the Organize Preset Group dialog box.
•Preset Group 
Lists the preset setups saved in the preset group.  The Select All, Unselect All, Rename, 
Duplicate, and Delete buttons are available to select or organize the setups saved in the preset 
group.
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Exercise 2

Perform Quick Test.

1. Open or create your preset group.

2. Edit your preset group as you want (changing the 
test execution order etc.).

3. Save your preset group. 

4. Connect device (MOSFET).

5. Perform Quick Test.

Time to complete: 5 minutes.

Note:
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Result Example

Note:
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To Control B2200 Switching Matrix

Step 1: Click Switching Matrix button to open the Switching Matrix Operation Panel.

Step 2: Enter the switch setup name.

Step 3: Define the switch setup by using the matrix on the operation panel window.  Label can be 
set to input ports and output channels.

Step 4: Click the Apply Switch Setup button to send the switch setup to the B2200 switching 
matrix.

Note: 
Before clicking this button, connect the B2200 to the B1500 via GPIB, and set the configuration.  
To set the configuration, see Module 8.

The switch setups you create or modify MUST be saved in a preset group.

To save the setup, click the Save button.

To recall the setup, click the Recall button.

You can organize the setups by using the Preset List button. 

To select the available preset group, use the field below the Preset List button.  In the above 
example, the DemoSW group is selected and listed in the Preset List list.

To rename, duplicate, or delete the setups, and to add, rename, duplicate, or delete the preset 
group, use the function of the Preset List button menu or the Organize Preset Group dialog box 
shown in the next page.
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To organize preset group for switch setup 

Preset List     button

This dialog box is opened by selecting the Organize Preset Group function of the Preset List 
button menu, and is used to organize the switch preset group.
•Preset Group List
Lists the preset groups saved in the workspace.  The Add, Rename, Duplicate, and Delete buttons 
are available to organize the preset groups.
•Copy 
Sets the operation of the >> button and the << button. They work as Copy when this check box is 
checked, and as Move when this check box is blank.
•>> 
Copies or moves the preset setup selected in the left Preset Group box to the right Preset Group 
box.
•<< 
Copies or moves the preset setup selected in the right Preset Group box to the left Preset Group 
box.
•Close 
Closes the Organize Preset Group dialog box.
•Preset Group 
Lists the preset setups saved in the preset group.  The Select All, Unselect All, Rename, 
Duplicate, and Delete buttons are available to select or organize the setups saved in the preset 
group.
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To add switch setup to test preset group

Switch setups can be saved in the preset group for test setups.
Click the Export to Current My Favorite Group button.  The switch setup will be converted to a 
classic test setup and saved in the My Favorite Setup group opened in the main screen.

To select the available preset group, use the Preset Group field.  In the above example, the Demo 
group is selected and listed in the quick test setup list.

To duplicate, import, or export the preset group, use the function of the My Favorite Setup banner 
menu or the Organize Preset Group dialog box shown in the next page.



2-30

Exercise 3

Add switch setup to test preset group.

1. Create a switch setup.

2. Create your switch preset group, and save your 
setup. 

3. Add the switch setup to your test preset group.

4. Save your test preset group. 

Time to complete: 5 minutes.

Note:
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To Manage Data Display Window
Data Display > Default Data Display Properties…

The Data Display Properties window is used to set the default setting of the Data Display window.  
This window is opened by selecting the Data Display > Default Data Display Properties... menu of 
the main screen.

The Effective Area is used to select the area effective when the Data Display window is opened, 
and provides the following check box.

•X-Y Graph: Check this box to enable the X-Y Graph area.

•Grid ON: Check this box to display the grid in the X-Y Graph.

•List Display: Check this box to enable the List Display area.

•Parameters: Check this box to enable the Parameters area.

The Graph Color area is used to set the color map of the Data Display window.  You can change 
the color of the graph background, text, graph grid, and line.  The color palette is opened by 
clicking the pattern of the item.

The Graph Trace Color area is used to set visibility, color, and thickness of the data traces Y1 to 
Y8 plotted in the graph.
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To Manage Data Display Window
Data Display > Manage Data Display…

The Data Display Manager is used to control the appearances of the Data Display windows.  This 
window is opened by selecting the Data Display > Manage Data Display... menu of the main 
screen. 
The Data Display Window Order area lists the Setup Name of the Data Display windows opened.  
The list items from top to bottom correspond to the windows from front to back in the screen 
image. 
The Minimized Data Displays area lists the Setup Name of the Data Display windows minimized. 
The Data Display Window Configuration area provides the following radio buttons and a check 
box to change the appearances of the Data Display windows.  All functions are available for the 
opened windows.  See following slides for the display examples.

•Keep Setup: Keeps the present configuration of the Data Display windows.

•Tiling: Resize and collate the data display windows such that they fill up the entire screen.

•Stacking: Resize and collate the data display windows so that they overlap slightly with an offset.

•Overlaying: Resize, overlap, and make transparent the data display windows so that multiple 
graphs can be viewed and superimposed on one another.

The following check box must be checked to apply the same graph scale to all graphs.

•Apply same scale to all graph
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Tiling

This is a display example of Tiling.



2-34

Stacking

This is a display example of Stacking.
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Overlaying

This is a display example of Overlaying.
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To tile/stack/overlay windows
Stacking

Tiling

Overlaying

When some Data Display windows are opened, the following Windows menu functions are 
useful.

Tiling

Tiles all Data Display windows on the screen.

Stacking

Stacks all Data Display windows on the screen.

Overlaying

Overlays all Data Display windows on the screen. Then the position, window size, and visibility of 
the most front window are applied to all windows on the screen.

The background of the X-Y Graph area is cleared except for the most back window.
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Module 3. Data Display and Management
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In This Module
• Data Display window
• Graph Analysis Tools
• Data Status
• To Change Graph/List/Display Setup
• To See Print Preview
• To Print Display Data
• To Copy Graph Plot/List Data
• To Save Analysis Result
• To Use Preview Window

This section describes the above topics.  You will understand how to use analysis tools, how to 
change display setup, and how to print/export test result.
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Data Display window

X-Y Graph PLot Parameters

List Display

The Data Display window is opened after measurement automatically, or by clicking the Data 
Display button. And the window is used to display measurement data and analyze the data.

The Show X-Y Graph icon displays/hides the X-Y Graph Plot area.  This is the same as the View > 
X-Y Graph menu.

The Show List Display icon displays/hides the List Display area.  This is the same as the View > 
List Display menu.

The Show Parameters icon displays/hides the Parameters area.  This is the same as the View > 
Parameters menu.
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Graph Analysis Tools

active line (normal line)
active cursor

cursor

marker
line (tangent line)

marker

This bar indicates 
which axis is 
effective for 
marker control and 
auto scaling.

cursor/marker position
(X value, Y1 value, Yx value)

Y1 Yx     (x : 2 to 8)

The Data Display window provides marker, cursors, and lines for analyzing test result data.  
Marker is used to read measurement data and draw a tangent line. Cursors are used to read the 
cursor position and draw a normal line, gradient line, or regression line.  The cursor/marker 
position data is displayed top of the graph plot area.

Clicking Y axis can select the Y axis effective for the analysis tools.  On the graph, left axis is 
always Y1 axis.  And the right axis is selectable from Y2 to Y8 axes.
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Graph Analysis Tools

Line Information:
Y1 intercept and 
gradient of 
active line

Line Information:
Yx intercept and 
gradient of 
active line

Line Information:
X intercept of active line

Show Graph Legend
Show Line Information

Graph Legend

When a line is displayed, the line information can be displayed in the graph plot area.  

The Show Line Information icon displays/hides the line information.  This is the same as the 
View > Line Information ON/OFF menu.

The Show Graph Legend icon displays/hides the graph legend.  This is the same as the View > 
Graph Legend ON/OFF menu.
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Graph Analysis Tools

Y1

Switch Display Mode

Hold this layer

Close this layer

Close All Displays

Layer selection tab.

This example has
three layers.

If the append measurement is performed, the data display layer is added to the Data Display 
window.  In this example, the Data Display window has three layers.

Use the icons shown above to organize the data display layers. 

Switch Display Mode icon switches the mode, overwrite or append.

In the overwrite mode, the data is displayed in a new Data Display window.

In the append mode, the data is displayed on a new display layer in the present Data Display 
window.

The Data Display window can hold up to 10 display layers.  And the earliest layer over 10 will be 
automatically deleted.  The Hold this layer icon is available when the window holds at least two 
layers.  If this icon shows the standing pin, the layer will be held.  If this icon shows the laid pin, 
the layer can be deleted.  Double clicking the tab gives the same result as this icon.
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Graph Analysis Tools
Graph control

Marker control

cursor/marker position
(X value, Y1 value, Yx value)

marker
line (tangent line)

marker

Graph control:

Auto Scale icon changes graph scale to fit the trace in the graph automatically for the Choose 
Active Y Axis.

Zoom In icon zooms the data graph in.  This enlarges the trace in the graph.  Then the center of 
zooming will be the cursor position.

Zoom Out icon zooms the data graph out.  This reduces the trace in the graph.

Graph Setup icon opens the Graph Setup dialog box used to change the graph axis setup.

Choose Active Y axis icon selects the Y axis that is effective for the analysis tools (marker control 
and auto scaling).

Marker control:

Marker ON/OFF icon enables or disables the marker.

Interpolation ON/OFF icon enables or disables the interpolation function of measurement data. 
You can read the interpolation data between two actual measurement points.

Marker Skip icon moves the marker to the next measurement curve that is added by the VAR2 
variable.

Marker Maximum icon moves the marker to the maximum measurement point.

Marker Minimum icon moves the marker to the minimum measurement point.

Marker Search icon opens the Direct Marker/Cursor dialog box used to specify the coordinate 
values to move the marker.
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Graph Analysis Tools
Line control

active line (normal line)
active cursor

cursor

marker
line (tangent line)

Line control:

Line 1 State icon enables or disables line 1 and its function: normal, gradient, tangent, or 
regression.

Line 2 State icon enables or disables line 2 and its function: normal, gradient, tangent, or 
regression.

Cursor to Marker icon moves the cursor to the marker position.

Adjust Gradient icon is available when a regression line is active. Clicking this icon enables the 
rotary knob and the mouse wheel to increase/decrease the gradient of the line.  Clicking this icon 
again, clicking the rotary knob, or clicking the mouse wheel disables this function.
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To Enable Analysis Tools
Marker > Marker ON/OFF Line > Line 1 ON/OFF

Line 2 ON/OFF

Marker ON/OFF Line 1 & Line 2

To enable maker, click the Marker ON/OFF icon, or select the Marker > Marker ON/OFF menu.

To enable the Line 1, click Line 1 icon and select one of the line mode.  Or select the Line > Line 1 
ON/OFF menu and select one of the line mode.

To enable the Line 2, click Line 2 icon and select one of the line mode.  Or select the Line > Line 2 
ON/OFF menu and select one of the line mode.

If you enable the Normal line, two cursors are available.  The cursors specify the points that the 
line passes through.

If you enable the Gradient line, a cursor is available.  The cursor specifies the point that the line 
passes through.

If you enable the Regression line, two cursors are available.  The cursor specify the measured 
data used to draw the regression line.
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To Draw Normal Line

2 cursors line

Line N > Normal
Cursor To Marker

Enable the Normal line by clicking the Line 1 (or Line 2) icon and Normal. 

Move cursors to draw the line.  The line passes through the cursor points. 

To move the cursor, you can use the Cursor To Marker icon.  The cursor will move to the marker 
point.
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To Draw Gradient Line

1 cursor
line

gradient

Adjust Gradient

Line N > Gradient
Cursor To Marker

Enable the Gradient line by clicking the Line 1 (or Line 2) icon and Gradient. 

Move the cursor to specify the point that the line passes through.  And click the Adjust Gradient 
icon.

Use the rotary knob or the marker scroll button to adjust the gradient of the line.

To move the cursor, you can use the Cursor To Marker icon.  The cursor will move to the marker 
point.
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To Draw Tangent Line

marker
line

data curve

Line N > Tangent

Enable the Tangent line by clicking the Line 1 (or Line 2) icon and Tangent. 

Move marker to draw the line.  The tangent line will pass through the marker point.
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To Draw Regression Line

line
2 cursors

measured data

Cursor To Marker
Line N > Regression

Enable the Regression line by clicking the Line 1 (or Line 2) icon and Regression. 

Move cursors to specify the region of the measurement data used for the regression calculation.

To move the cursor, you can use the Cursor To Marker icon.  The cursor will move to the marker 
point.
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Data Status

If measurement unit detects any status while measurement, the status code is recorded with the 
measurement data.  In this example, a SMU detected the compliance condition in the drain 
channel, so the status code C is put just before the Idrain value.

SMU status code:

• C: Compliance

• T: Other channel compliance

• X: Oscillation

• V: Overflow

MFCMU status code:

• U: Unbalance

• D: I/V amp saturation

• V: Overflow
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To Change Graph Properties
Edit > Graph Properties…

Variety of thickness

The Graph Properties dialog box is used to set the following setting of the selected Data Display 
window.  This dialog box is opened by clicking the Properties... button in the X-Y Graph Plot area 
or by selecting the Edit > Graph Properties... menu of the Data Display window.

The Grid ON check box in the Effective Area is used to display the grid in the X-Y Graph.

The Graph Color area is used to set the color map of the Data Display window.  You can change 
the color of the graph background, text, graph grid, and line.  The color palette is opened by 
clicking the pattern of the item.

The Graph Trace Color area is used to set visibility, color, and thickness of the data traces Y1 to 
Y8 plotted in the graph.
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To Change List Display Properties
Edit > List Display Properties…

Example: -1.2345 mA
Example: -1.23456789012345E-003 A

Example: C -1.2345 V

Data Status
Physical Unit

This dialog box is used to set the data display format in the List Display area.  This dialog box is 
opened by clicking the Properties... button in the List Display area or by selecting Edit > List 
Display Properties... menu of the Data Display window. 

Display: 
Check the following check box to add the data status or the physical unit to data. Unchecking the 
box removes it.

•Data Status: Adds or removes the status code before data.

•Physical Unit: Adds or removes the physical unit after data.

Number Format:
Selects the data display format from the following formats.

• Engineering Format (with Unit Prefix):
Data display with arithmetic point, SI prefix, and unit.
Example: -1.2345 mA

• Scientific Notation:
Data display with arithmetic point, exponential part (E, +/- sign, and three-digit number), and unit.
Example: -1.23456789012345E-003 A
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To Change Display Setup
View > Display Setup…

This dialog box is used to change the graph scale and data displayed in the Data Display window.

The X-Y Graph area sets the X axis and Y axis of the X-Y Graph Plot area.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

The List Display area selects the variables to be listed in the List Display area.  Up to 20 variables 
can be set.

The Parameters area selects the variables to be listed in the Parameters area.  Up to 20 
parameters can be set.
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To See Print Preview
File > Print Preview…

The Data Display window provides the File > Print Preview… function to show the print preview.  
This is an example of the print preview.

•Select the File > Print Preview menu to open the Print Preview dialog box.

•Set the Print Range, Data to print, and Scaling.

•Click Preview button.  The Print preview window is displayed.
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To Print Display Data

bmp, emf, gif, or png format

Edit > Graph Properties… Edit > Save Image As…

The Data Display window provides the display image output capability to a printer or a file.

Before printing, connect a printer to the B1500A via the parallel interface or the LAN, and set up it 
by using the Add Printer Wizard of Windows.  After that, do following.

•Select the File > Print menu to open the Print dialog box.

•Set the Print Range, Data to print, and Scaling.

•Click Next button.

•Select the printer, and set the Properties.

•Click OK button.

You can export the display image to a file as shown below.

•Select the File > Save Image As… menu to open the Save Image As… dialog box.

•Select the format (file type) from Save As Type menu.

•Enter the file name.

•Click Save button.

The file can be imported by the graphics software that supports the exported file type.  The 
EasyEXPERT supports the following types.

•bmp: Bitmap image

•emf: Enhanced metafile

•gif: GIF image

•png: PNG image
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To Copy Graph Plot

Paste to WordPad

You can copy graph image to the clipboard, and paste it to a word processing software.  In the 
above example, the graph image is pasted to the WordPad.

This is an example of the copy and paste operation.

•Select the Edit > Copy Graph menu on the Data Display window.

•Select the Edit > Paste menu on the WordPad.
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To Copy List Data

Paste to Notepad

Read by Spreadsheet software

You can copy the data list to the clipboard, and paste it to a word processing software.  In the 
above example, the data list is pasted to the Notepad.

This is an example of the copy and paste operation.

•Select the Edit > Copy List menu on the Data Display window.

•Select the Edit > Paste menu on the Notepad.

You can save the data as a text file, and read it by using a spreadsheet software.  Data elements 
are separated by a tab.

Note:
As same as the Copy List function, the Copy Parameter function is used to copy the data in the 
Parameter area.
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To Save Analysis Result
Select File > Update Test Result
Select File > Save Image As…

Saves graph information to data record.
Saves graph image as a file.

To leave the graph modification information such as scaling, marker, cursor, and line on the 
graph, select the File > Update Test Result menu.

You can see the all information when you open the graph again.  Note that the modification 
information will be destroyed if you did not do it. 

To save the graph image as a file, select the File > Save Image As… menu.

You can save the image as a bmp, emf, gif, or png file.
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Exercise 4
Use the analysis tools.

1. Use your test setup and perform measurement as 
shown in Exercise 1.

2. Enable marker and draw line.  Try it for all line types.

3. Copy/paste/save data list, and open it by using a 
spreadsheet software (optional, if you can).

4. Save analysis condition.  Re-open the test record.

5. Export your test record.  And import it. 

Time to complete: 10 minutes.

Note:
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To Use Preview Window

The Data Display window provides the File > Print… function to print the graph image.  However, 
you may want to set the graph title and change the line style.  Then use the Preview window.  
The Preview window is used to see and print the graph image you modified.

Select the View > Open Preview Window to open the Preview window and the Preview Settings 
dialog box.  And use the Preview Settings dialog box to set the title of graph, X axis, and Y axis, 
and change the line style.  To change the color and thickness, use the Color and Thickness dialog 
box opened by clicking the Color and Thickness… button.

Clicking OK button in the Preview Settings dialog box applies the modification to the Preview 
window and closes the dialog box.

Note:
The graph image in the Preview window cannot be saved.
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To Use Preview Window

This example is result of the changes shown in the previous page.

Line style was changed as shown above.  The titles are set as follows.

Graph title: ID-VG Characteristics

X axis title: Gate Voltage

Y1 axis title: Drain Current

Y2 axis title: Transconductance

Y3 axis title: Drain Current

Also color of line1 was changed to red, and thickness of trace was changed.

To change the setup again, open the Preview Settings dialog box by selecting the View > Preview 
Settings… menu.
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Exercise 5
Use the Preview window.

1. Use your test record used in Exercise 4.

2. Change the graph image as you want.
- Add graph title and change axis title.
- Change line style
- Change color and thickness

3. Print the graph image if a printer is available. 

Time to complete: 5 minutes.

Note:
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Module 4. Modifying Application Test Definitions



4-2

Modification Overview

1. Open an application test definition to be modified
2. Open test definition editor
3. Save the definition as your test definition
4. Modify the definition as you like
5. Resave and close the definition
6. Export your test definition
7. To Use Built-in Functions
8. To Use Auto Analysis Function in Test Contents
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To Open an Application Test Definition
Example: Select Vth gmMax as template

Click a test definition in Library list area, and click Select button to open the test definition.

For example, open Vth gmMax.
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To Open Test Definition Editor
Click Library/Open Definition of This Test…

Cancel
Define New Test…
Open Definition of This Test…
Delete Definition of This Test
Import Test Definition…
Export Test Definition…

Click Library and select Open Definition of This Test… to open the test definition editor.
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To Save Definition As Your Definition
Save the definition as your definition (ex: Trng vth)

Save   Ctrl+S
Close

Test Definition editor

After changing test name, save as new name (ex. Trng vth).  Saving the definition changes the 
window title to the new test name.  Window title will be changed from Vth gmMax to Trng vth in 
this example.
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To Modify Test Definition
Change default values, and add parameters (ex: Pcomp_d)

This area sets the 
properties of the 
specified parameter.

•Min
•Max
•Digits
•Resolution
•Unit
•Typical Values
•Symbols

Test Definition editor

On the Test Specification tab screen, you can add new parameters or change parameter settings.  
The above example adds the Pcomp_d test parameter. 

For example:

Name=Pcomp_d, Type=Numeric, Default=1 mV, Description=Power compliance for drain 
terminal, Align=check, X=550, Y=120, Width=80, Ext=uncheck

Properties: Min=1 mW, Max=100 mW, Digits=4, Resolution=1 mW, Unit=W

For Align, X, Y, and Width values, see the values of the entry fields for the same terminal. For 
example, Pcomp_d must be put between Vd and Subs entry fields.

Typical Values… button opens a dialog box used to define the typical values used for the 
selections of the parameter value in the Application Test mode. For example, set 1 mW to 10 mW
in 1 mW step.

Symbols… button opens a dialog box used to map a numeric value to a string. For example, 
Value=1 and Symbol=ON are set, typing ON enters 1, and typing 1 enters ON. The value must 
satisfy the Min, Max, Digits, and Resolution settings. The value and the symbol must be one by 
one. The definition is effective only for the parameter.
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To Modify Test Definition
Change or set test parameters (ex: Pcomp_d)

Test Definition editor

On the Test Contents tab screen, you can change the test execution flow (program flow), 
measurement conditions, display setup, and so on.

To add the Pcomp_d parameter to the measurement setup, click the Vth_gmmax line in the 
program list.  Then I/V Sweep setup editor is displayed.  In the editor, display the Measurement 
Setup tab screen.  And enter Pcomp_d to Pwr Comp entry field.
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To Modify Test Definition
Change display setup (ex: Y axis Max value)

For example, 
change Max value 
to 1/10.

Test Definition editor

Next, display the Display Setup tab screen.  And change the Y axis Max values.

For example, add /, 1, and 0 at the last of entry field to change the Max value to 1/10.



4-9

To Modify Test Definition
Add local variable (ex: Yes and No) for Message box

Test Definition editor

Variables Yes and 
No are used in the 
message box.

On the Test Contents tab screen, add program lines in the test execution flow.  In this section, the 
following lines are inserted between the Vth_gmmax line and the Auto Analysis line.

Message

IF Yes=0

END

END IF

This will open the message box after the measurement is completed and before the auto analysis 
is performed.

At first, the variables used in the message box.  For example, Yes and No variables are defined.

Click Local Variables Definition line to display the local variable list shown above.  And define the 
variables.

Example:

Name=Yes, Value=0, Description=User response

Name=No, Value=0, Description=User response
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To Modify Test Definition
Define Message box

Test Definition editor

Yes and No buttons 
are made on this 
message box.

This message box 
asks if you want to 
perform auto 
analysis or do not.

Variables.
Yes=1/No=0 if Yes 
button is clicked.
Yes=0/No=1 if No 
button is clicked.

Next, click the Message line in the program list.  The editor change the display as shown above.

1. Enter the message.

2. Enter the button name. 

3. Select the variable used to keep the status of the button.

4. Repeat 2 and 3 for all buttons you want to add.
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To Modify Test Definition
Add branching (ex: auto analysis is performed if Yes button is pressed)

Test Definition editor

The lines terminate 
the test if No button 
is clicked.

At last, insert the branching lines.  The example above terminates the test execution if the No 
button is clicked on the Message box, without performing auto analysis.
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To Modify Test Definition
Example: Displaying Message box

After measurement 
is performed, the 
message box will be 
displayed.  

The message box 
asks if you want to 
perform auto 
analysis or not.

This is the example image when the Message box is displayed on the screen after the 
measurement is completed.
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To Use Debug Tools

Break point

ReturnPort = SMU1

ReturnCh = OUT1

Variable Inspector

This slide shows an example of using the Variable Inspector for debugging.  Confirm whether the 
correct values are passed to the variables properly.

Set the break point, and click the Run button.  After the program is paused, click the Inspect 
button.  The Variable Inspector is displayed.  You can check the values by using the variable 
display fields.  The field can be displayed by using the Add XXXX Variable button.  XXXX will be 
Numeric, Vector, String, or Module.
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To Resave and Close Your Test Definition
Close the definition editor, and overwrite your test definition

Save   Ctrl+S
Close

Test Definition editor

After you create your test definition, save the definition and close the Test Definition editor.

Click File > Close.  Confirm Test Definition Save dialog box is opened.  Click Yes to save your test 
definition and continue the close operation.  The Confirm Test Definition Overwrite dialog box is 
opened.  Click OK to overwrite your test definition.
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To Export/Import Test Definition
Click Library/Export Test Definition or Import Test Definition

Cancel
Define New Test…
Open Definition of This Test…
Delete Definition of This Test
Import Test Definition…
Export Test Definition…

The test definition can be exported as the EasyEXPERT test definition file format or XML file 
format.  And the file can be imported to the EasyEXPERT later.
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Exercise 6
Modify test definition.

1. Select Vth gmMax test definition and open it.

2. Modify it as shown in page 4-6 to 4-11.

3. Save it as Trng vth, and perform test.

4. Add program lines to start Id-Vd test by Yes button.

5. Save it as Trng vth2, and perform test.

6. Export it, and import it. 

Time to complete: 10 minutes.

Note:
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Modification Example

Test Definition editor

The lines perform auto analysis if Yes 
button is clicked.

The lines perform Id-Vd measurement 
if Yes button is clicked

Modification example for step 4.

! ***** Analysis *****

Message

If Yes=1

Auto Analysis

END IF

! ***** Id-Vd *****

Message

If Yes=1

Id-Vd

END IF

Setup example of the first message box:

Message=Do you want to perform auto analysis?

Button 1: Label=Yes, Selected=Yes

Button 2: Label=No

Setup example of the second message box:

Message=Do you want to perform Id-Vd measurement?

Button 1: Label=Yes, Selected=Yes

Button 2: Label=No
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To Use Built-in Functions
Absolute value: abs(A)
Averaging: avg(A), mavg(A,B)
Data conversion: string(A), value(A)
Difference: delta(A)
Differentiation, integration: diff(A,B), integ(A,B)
Exponent, logarithm: exp(A), lgt(A), log(A)
Maximum, minimum: max(A), min(A) 
Reading data : getNumericData(A), getVectorData(A)
Square root: sqrt(A)
Trigonometric function: acos(A), asin(A) , atan(A), atan2(A,B), 

cos(A), sin(A), tan(A) 

The EasyEXPERT software provides the built-in functions to calculate the display data and 
parameter and to get the test result data.  The built-in functions can be used in the user function 
and analysis function of the test setup, and in the test execution flow of the test contents.  For 
details of the functions, see User’s Guide or online help.

The following functions are also available.

at(A,B), at(A,B,C), ceil(A), cond(A,B,C,D), dim1Size(A), dim2Size(A), floor(A), index(A,B), 
isValid(A), setDeviceId(A), storeAt(A,B,C,D), substring(A,B,C), swmToModule(A)
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To Use Built-in Functions
User function setup example

gm = diff(Id,Vg)
gmMax = max(gm)

GM_MAX=getVectorData(gmMax)
VTH=getNumericData(Vth)
GM=getVectorData(gm)
ID=getVectorData(Id)
VG=getVectorData(Vg)

This is an user function setup example.  This example uses the diff function to calculate gm 
values and the max function to get the maximum gm value.

Also, the getVectorData and getNumericData functions are used in the test execution flow to get 
the test result data.



4-20

To Use Read Out Functions

Marker index value: @MI
X coordinate value: @MX, @CX
Y coordinate value: @MY, @MYn, @CY, @CYn
Regression line parameter: @L1CO, @L2CO
Line slope: @L1G, @L1Gn, @L2G. @L2Gn
Line X intercept: @L1X, @L2X
Line Y intercept: @L1Y, @L1Yn, @L2Y, @L2Yn
Intersection of lines: @IX, @IY, @IYn

n: integer. 1 to 8.

The EasyEXPERT software provides the read out functions to read the marker position, cursor 
position, line slope, line intercept, and so on.  The read out functions can be used in the analysis 
function of the test setup.
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To Use Read Out Functions
Analysis function setup example

Vth = @L1X

This is an analysis function setup example.  This example uses the @L1X function to get the X 
intercept value of the line 1.
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To Use Auto Analysis Function
Analysis: Auto Analysis

• Line 1
• Line 2
• Marker

GM=GM_MAX

The Auto Analysis statement provides the setup editor used to set up the automatic analysis 
function.  When a measurement finishes, the function automatically draws lines, a marker, or 
both on the X-Y Graph of the Data Display window.

You can set up two lines and one marker for the automatic analysis function by using the setup 
editor.

In the Line 1 and Line 2 areas, you can set up the lines to be drawn.

In the Marker area, you can set up the marker.

The above example draws the tangent line for the Y1 data at the maximum GM point. 
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To Use Auto Analysis Function

Interpolation

Line 1 setup

Line 2 setup

Marker setup

The auto analysis capability allows you to display/move the marker/line on the data graph 
automatically after measurement.  The above example is the Vth gmMax test definition.

To add the auto analysis operation to your test definition, open your test definition and do the 
procedure shown above (1 to 5).  The Auto Analysis component can be added to your definition.

Interpolation Mode 

Check this box to enable the interpolation mode. You can position marker between measurement 
points. 

Line 1, Line 2

This area sets the line 1 or line 2 automatically displayed and moved to the specified position 
after the measurement.

Check Enable box to enable the line.

For Type, select a line type, Normal, Gradient, Tangent, or Regression.

For Axis, select the axis effective for the line.

In First Point and Second Point, specify the cursor points used to draw line.

In Gradient, specify the slope of the Gradient line.



4-24

To Use Auto Analysis Function

Interpolation

Line 1 setup

Line 2 setup

Marker setup

Marker 

This area sets the marker automatically displayed and moved to the specified position after the 
measurement.

Check Enable box to enable the marker.

For Condition, enter a variable name and a condition expression to specify where you want the 
marker to display.

For After, check this box to enable the additional condition.  And enter a second variable and 
condition expression. This sets up a search start condition for finding specified point.

For example, you can specify the following expressions to search for a measurement point that 
satisfies the first condition after the second condition is satisfied.

Condition: [DGM] = [MAX(DGM)*0.01] [x] After [DGM] = [MAX(DGM)]
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To Use Auto Analysis Function

User Function

Analysis Function

In the Vth gmMax test definition, the user functions and analysis functions are defined to use the 
auto analysis function.  See the previous slide.  The analysis function enables the line 1 for the Y1 
data and displays the tangent line at the X-coordinate that takes the maximum gm value.

The following user function is used to calculate the gm value.

Gm = diff(Idrain, Vgate)

The following user function is used to get the maximum gm value.

gmMax = max(gm)

The following analysis function is used to get the Von value.  The readout function @L1X gives 
the X intercept value of the line 1.

Von = @L1X

The following analysis function is used to calculate the Vth value.

Vth = Von – (Vd*Polarity/2)

Where, Polarity is –1 for P-ch MOSFET or 1 for N-ch MOSFET.
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To Add Data Display
Analysis: Display Data Setup

Data display

Measurement, 
data display, and 
data save

The test setup performs measurement and displays the test result as defined in the channel 
setup, measurement setup, and display setup.  And the test result data will be stored to the test 
record.

In addition to the default test result display, you can make additional data display by using the 
Display Data Setup statement.  The statement provides the user interface as same as the Display 
Setup of the Classic Test or the Test Output of the test definition.  The above example displays 
the ID-VG/GM-VG curves, GM_MAX and VTH values, and tangent line by using the extra Data 
Display and Auto Analysis function.  See next slide.

Note:
The additional display data cannot be saved to the data record. However only the last display 
data can be saved if the Test Output is not defined in the test definition.
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To Add Data Display
Additional data display example

This is a test result example displayed on the Data Display window.
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To Control Test Result Data Outputs

Analysis: Data Display Control

Data Display: OFF/ON

Miscellaneous: Data Store Control

Data Store: OFF/ON

By the default setting, the results of the tests defined in your test definition are displayed on the 
Data Display window and are stored to the data record.

You can control the data display of the tests by using the Data Display Control statement.  Insert 
the statement, and remove the check from the Enable Data Display box to disable the data 
display.

You can control the data storage of the tests by using the Data Store Control statement.  Insert 
the statement, and remove the check from the Enable Creating Test Result Record box to disable 
the data storage.

This function is not available for the following data.  The data output is always enabled.

•Data output set to the Test Output of the test definition

•Data output of the last test setup if the Test Output is not set
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Module 5. Using Classic Test Environment
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Classic Test Execution Mode

• I/V Sweep
• I/V-t Sampling
• C-V Sweep
• Switching Matrix Control

To use the classic test mode, click the Classic Test tab.  And select the execution mode.  The 
following modes are available.

•I/V Sweep: For X-Y characteristics measurement of I or V.

•I/V-t Sampling: For time-Y characteristics measurement of I or V.

•C-V Sweep: For DC bias-impedance characteristics measurement.

•Switching Matrix Control: For B2200 switching matrix control.
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I/V Sweep Measurement

• To Define Source/Measurement Channels
• To Read Time Stamp Data and Data Index
• To Set Source Outputs (VAR1, VAR2, VAR1’, Pulse, CONST)
• To Set Timing Parameters
• To Set Sweep Abort Function
• Range, ADC/Integ, Advanced
• To Set User Functions
• To Set Analysis Functions
• To Set Auto Analysis Function
• To Set Display Parameters (X-Y Graph, Data List, Parameter)

This section explains how to perform I/V sweep measurement.  You will perform the above tasks 
to execute the I/V sweep measurement.
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Channel Setup

Channel Definition
-SMU
-V name/I name
-I/V/IPULSE/VPULSE/COMMON
-VAR1/VAR2/VAR1’/CONST

Setup Name

SMU1

SMU3

SMU4

SMU2

To Define Source/Measurement Channels

Click the I/V Sweep icon and open the setup editor.  Then click the Channel Definition tab to 
display the channel definition screen. 

•Enter the Setup Name for the test setup to be defined on the setup editor.

•List SMUs used for source output or measurement, and set the following parameters.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), VPULSE (voltage pulse), IPULSE (current 
pulse), or COMMON (ground)

•Function: Source output function, VAR1 (primary sweep), VAR2 (secondary sweep), VAR1’
(synchronous sweep), CONST (constant)

V Name and I Name are used to specify the parameters displayed on the Data Display window.  
The display parameters are selected on the Display Setup tab screen.
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To Read Time Stamp Data and Data Index
Channel Setup

Variable name for time stamp data

Variable name for data index

You can read measurement data by using the Data Display window. Parameters displayed on the 
window are selected on the Display Setup tab screen.  If you enter the variable name in the V 
Name, I Name, Time Stamp Name, and/or Index Name entry fields, you can choose the variables 
as the display parameters.

•The time stamp is the time the measurement is started for each measurement point.

•The index is the index number for each measurement data.
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To Set Primary Sweep Source
Measurement Setup

Start

Stop
Step

VAR1

The Measurement Setup tab screen is used to set the source output value and timing parameters.  

At the VAR1 area, you set the primary sweep source output.

•Unit: SMU name or number

•Name: Variable name of source output

•Direction: Single (start to stop) or Double (start to stop to start)

•Linear/Log: Linear sweep or Log sweep

•Start: Source output start value

•Stop: Source output stop value

•Step: Source output incremental step value

•No of Step: Number of sweep steps

•Compliance: SMU compliance value

•Pwr Comp: SMU power compliance value
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To Set Secondary Sweep Source
Measurement Setup

VAR2

VAR1

At the VAR2 area, you set the secondary sweep source output.

•Unit: SMU name or number

•Name: Variable name of source output

•Start: Source output start value

•Stop: Source output stop value

•Step: Source output incremental step value

•No of Step: Number of sweep steps

•Compliance: SMU compliance value

•Pwr Comp: SMU power compliance value
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To Set Synchronous Sweep Source
Measurement Setup

VAR1’

VAR1

At the VAR1’ area, you set the synchronous sweep source output.

•Unit: SMU name or number

•Name: Variable name of source output

•Offset: B value of the above formula.

•Ratio: A value of the above formula.

•Compliance: SMU compliance value

•Pwr Comp: SMU power compliance value

The VAR1’ output is expressed by the following formula.

VAR1’ output = A × (VAR1 output) + B
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To Set Pulse Output
Measurement Setup

Period
Hold time

Width Width

Delay time cannot be set.

Trigger

Base

At the SMU Pulse area, you set the SMU pulse timing parameter and the pulse base value.

•Unit: SMU name or number

•Period: Pulse period

•Width: Pulse width

•Base: Pulse base value

Only a SMU can be set to the pulse source.
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To Set Constant Output
Measurement Setup

At the Constants area, you set the SMU constant output.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), VPULSE (voltage pulse), IPULSE (current 
pulse), or COMMON (ground)

•Source: SMU output value

•Compliance: SMU compliance value



5-11

To Set Timing Parameters
Measurement Setup

Hold time
Delay time

Measurement time

Trigger

At the Timing area, you set the source output and measurement timing.

•Hold: Source output hold time. Time after the measurement trigger until starting delay time.

•Delay: Measurement start delay time. Time after the hold time until starting measurement.

When a SMU forces pulse, the delay time is ignored.  Source output and measurement timing will 
be controlled by the pulse width and pulse period.
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To Set Sweep Abort Function
Measurement Setup

CONTINUE AT ANY
STOP AT ANY ABNORMAL
-Range overflow
-SMU compliance
-SMU oscillation

This field sets the sweep abort function.

When this field is CONTINUE AT ANY, the sweep measurement is not aborted.

When this field is STOP AT ANY ABNORMAL, the sweep measurement will be aborted when one 
of the following conditions is detected.

•Measurement range overflow

•SMU compliance

•SMU oscillation
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To Set Ranging Mode
Measurement Setup

Not available when 
a pulse source is used

The Range button opens the SMU Range Setup dialog box.  The dialog box is used to set the 
measurement ranging mode.  This button is not available when a pulse source is used.

•Unit: SMU name or number

•Name: Variable name for the measurement data

•Mode: Ranging mode, AUTO, LIMITED, or FIXED

•Range: Range value

•Range Change Rule: BY FULL RANGE, GO UP AHEAD, or UP AND DOWN AHEAD

•Rate: Value used for range changing.  See the following formula.

For the AUTO or LIMITED, SMU automatically selects the minimum range that covers the 
measurement value, and performs the measurement by using the range.  For the limited auto 
ranging, the instrument does not use the range lower than the specified range value.  For 
example, if you select the 100 nA limited auto ranging, the instrument never uses the 10 nA range 
and below. 

BY FULL RANGE performs normal auto ranging operation.

For the GO UP AHEAD and UP AND DOWN AHEAD rules, specify the Rate value, 11 to 100, which 
fixes the boundary of the ranging. The ranging occurs when the measurement data goes across 
the boundary values shown below.

go up boundary = present measurement range × Rate / 100

go down boundary = present measurement range × Rate / 1000

The go down boundary is available only for the UP AND DOWN AHEAD rule.
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To Set ADC/Integration Time
Measurement Setup

Not available when 
a pulse source is used

The ADC/Integ button opens the A/D Converter & Integration Time Setup dialog box.  The dialog 
box is used to select the ADC for each SMU and set the integration time for each ADC (high 

resolution or high speed).  This button is not available when a pulse source is used.
A/D Converter:

•Unit: SMU name or number

•Name: Variable name of the measurement data

•ADC: ADC type, HR ADC (high resolution) or HS ADC (high speed)

Integration Time:

•Mode: AUTO, MANUAL, or PLC.  Rule to decide the integration time.  For details, see online help 
or User’s Guide.

•Factor: Coefficient for the reference value of the integration time.

•Auto Zero: Auto Zero function ON or OFF.  For HR ADC.
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Advanced Setup
Measurement Setup

The Advanced button opens the Advanced Setup dialog box.  The dialog box is used to set the 
SMU filter and SMU series resistor settings, and set the wait time.

Channel Settings:

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Series R: SMU series resistor NONE or 1MOHM (1000000 ohm)

•SMU Filter: SMU filter ON or OFF

Wait Time Control:

•Factor: Coefficient for the reference value of the wait time.  For details, see online help or User’s 
Guide.

After Measurement Settings:

•Bias Hold after Measurement: Bias hold function ON or OFF.

•Output Value after Measurement: Source output value after measurement.  START (sweep start 
value), STOP (sweep stop value), SOURCE (sampling output source value), or BASE (sampling 
output base value)
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To Set Analysis Functions
Function Setup

Data calculation
-Measurement data/source data
-Built-in function, etc.

Click the Function Setup tab to display the User Function/Analysis Function setup screen.  The 
user functions can be displayed on the X-Y Graph Plot, List Display, and Parameters area of the 
Data Display window.  Up to 20 functions can be set.

Name: Function name

Unit: Unit of the function

Definition: Definition of the function.  The following identifiers can be used.
-Variables for the measurement/output data used in this test
-Functions defined in the above lines
-Local variables passed from the application test that calls this test as a component
-Built-in functions and global variables

For details, see online help or User’s Guide.

Note:
The Apply button performs calculation of the definition in this screen. If this button is clicked 
when the Data Display window associated with this test has been opened, the display is also 
updated.  The associated Data Display window will be the Data Display window that displays the 
last measurement data or that is recalled at last.
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To Set Analysis Functions
Function Setup

Data calculation
-Measurement data/source data
-Read out function
-Built-in function, etc.

The analysis functions can be displayed on the Parameters area of the Data Display window.  Up 
to 20 functions can be set.

Name: Function name

Unit: Unit of the function

Definition: Definition of the function. The following identifiers can be used.
-Variables for the measurement/output data used in this test
-Functions defined in the above lines
-Local variables passed from the application test that calls this test as a component
-Built-in functions and global variables
-Read out functions

For details, see online help or User’s Guide.

Note:
The Apply button performs calculation of the definition in this screen. If this button is clicked 
when the Data Display window associated with this test has been opened, the display is also 
updated.  The associated Data Display window will be the Data Display window that displays the 
last measurement data or that is recalled at last.
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To Set Auto Analysis Function

Interpolation

Line 1 setup

Line 2 setup

Marker setup

Auto Analysis Setup

Click the Auto Analysis Setup tab to display the auto analysis setup screen.  The auto analysis 
capability allows you to display/move the marker/line on the data graph automatically after 
measurement.  The above example displays marker at Vd=1 V point and draw a tangent line for 
this point.

Interpolation Mode:  Check this box to enable the interpolation mode. You can position marker 
between measurement points. 

Line 1, Line 2:  This area sets the line 1 or line 2 automatically displayed and moved to the 
specified position after the measurement.  Check Enable box to enable the line.

For Type, select a line type, Normal, Gradient, Tangent, or Regression.

For Axis, select the axis effective for the line.

In First Point and Second Point, specify the cursor points used to draw line.

In Gradient, specify the slope of the Gradient line.

Marker:  This area sets the marker automatically displayed and moved to the specified position 
after the measurement.  Check Enable box to enable the marker.

For Condition, enter a variable name and a condition expression to specify where you want the 
marker to display.

For After, check this box to enable the additional condition.  And enter a second variable and 
condition expression. This sets up a search start condition for finding specified point.

For example, you can specify the following expressions to search for a measurement point that 
satisfies the first condition after the second condition is satisfied.

Condition: [DGM] = [MAX(DGM)*0.01] [x] After [DGM] = [MAX(DGM)]

Note:
The Apply button performs calculation of the definition in this screen. If this button is clicked 
when the Data Display window associated with this test has been opened, the display is also 
updated.  The associated Data Display window will be the Data Display window that displays the 
last measurement data or that is recalled at last.
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To Set X-Y Graph Display
Display Setup

Specify X axis and Y axis

Click the Display Setup tab to display the display setup screen. The X-Y Graph area is used to set 
the X axis and Y axis of the X-Y Graph Plot area in the Data Display window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis
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To Set Data List Display
Display Setup

Select variables to list

The List Display area selects the variables to be listed in the List Display area of the Data Display 
window.  Up to 20 variables can be set.
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To Set Parameters to Display
Display Setup

Select parameters to display

The Parameters area selects the variables to be listed in the Parameters area of the Data Display 
window.  Up to 20 parameters can be set.
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To Save Test Setup

Preset Group name.
Use this field to 
select preset group.

My Favorite Setup button

The test setups you create MUST be saved to the internal hard disk drive as “My Favorite Setup”.

To save the setup, click the Save button.

To recall the setup, click the Recall button.

You can organize the setups by using Preset Group.  In the above example, the Demo group is 
selected and listed in the “My Favorite Setup”.

To create a new preset group, click the My Favorite Setup button to display the function menu, 
and select Add New Preset Group. 

To select the available preset group, use the field below the My Favorite Setup button.
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To Export/Import Your Preset Group

My Favorite Setup button

You can export/import your preset group.

To export the present preset group, click the My Favorite Setup button, select Export, and specify 
the folder and the name of the preset group to export. 

To import the preset group, click the My Favorite Setup button, select Import, and specify the 
preset group to import. 
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Exercise 7
Define test setup and perform test.

1. Click I/V Sweep icon and open setup editor.

2. Define test setup as shown in page 5-4 to 5-21.

3. Save it as Trng Id-Vd.

4. Connect device, and perform test.

5. Export preset group, and import it. 

Time to complete: 10 minutes.

SMU1

SMU3

SMU4

SMU2

Note:



5-25

Measurement Result Example

This is a test result example displayed on the Data Display window.
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I/V-t Sampling Measurement

• To Define Channels and Variables
• To Set Sampling Parameters
• To Set SMU Outputs (CONST)
• To Set Ranging Mode
• To Set User Functions/

Analysis Functions
• To Set Data Display

This section explains how to perform I/V-t sampling measurement.  You will perform the above 
tasks to execute the I/V-t sampling measurement.
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Channel Setup

GNDU

SMU5
Channel Definition
-SMU
-V name/I name
-I/V/COMMON
-CONST

Setup Name

Variable name for time stamp data
Variable name for data index

To Define Channels and Variables

Click the I/V-t Sampling icon and open the setup editor.  Then click the Channel Definition tab to 
display the channel definition screen. 

•Enter the Setup Name for the test setup to be defined on the setup editor.

•List SMUs used for source output or measurement, and set the following parameters.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), or COMMON (ground)

•Time Stamp Name: Variable name for the time stamp data

•Index Name: Variable name for the data index

You can read measurement data by using the Data Display window. Parameters displayed on the 
window are selected on the Display Setup tab screen.  If you enter the variable name in the V 
Name, I Name, Time Stamp Name, and/or Index Name entry fields, you can choose the variables 
as the display parameters.

•The time stamp is the time the measurement is started for each measurement point.

•The index is the index number for each measurement data.
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To Set Sampling Parameters
Measurement Setup

Hold time

Measurement time

Sampling interval

Trigger
Sampling parameter

Click the Measurement Setup tab to display the setup screen for the sampling timing parameters 
and the SMU source output parameters.  At the Sampling Parameter area, you set the following 
sampling timing parameters.

Linear/Log:
Sampling mode. LINEAR for linear sampling. LOG10, LOG25, LOG50, LOG100, LOG250, or LOG500 
for logarithmic sampling.  For the logarithmic sampling, the number after LOG indicates the 
number of measurement data in a decade. For example, LOG10 mode is used to get 10 
data/decade.

For the log sampling, the B1500A holds only the data that can be plotted on the log scale in the 
same distance as close as possible. Only the held data is counted in the number of measurement 
result data.

For the linear sampling with Interval < 2 ms, if the total measurement time runs over the specified 
time Interval × No of Samples, the sampling measurement will be stopped even if the number of 
measurement result data is less than the specified No of Samples.

Interval:
Interval of the sampling, in seconds. 0.002 to 65.535 s, 0.001 s resolution.

Interval < 0.002 s in 0.00001 s resolution is also available for the linear sampling.  It must satisfy 
the following formula.  For details, see online help or User’s Guide.

Interval ≥ 0.0001 + 0.00002 × (number of measurement channels-1)
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To Set Sampling Parameters
Measurement Setup

Hold time

Measurement time

Sampling interval

Trigger

Sampling parameter

No of Samples:
Number of samples. Integer. 1 to the following value.

For linear: 100001 / (number of measurement channels)

For logarithmic: 1 + (number of data for 11 decades)

Total Sampling Time:
This field just displays the total sampling time that is the time from the measurement start time 
for the first point to the end of sampling measurement. It does not include the hold time.

Total Sampling Time = Interval × No of Samples

Output Sequence:
Source output sequence. SIMULTANEOUS or SEQUENTIAL. 

Hold Time:
Time since the Source value output until the first sampling point, in seconds. 0 to 655.35 s, 
resolution 0.01 s.

The following values are also available for Interval < 0.002 s.  |Hold Time| will be the time since 
the sampling start until the Source value output.

-0.09 to -0.0001 s, resolution 0.0001 s.

Base Hold Time:
Hold time of the Base value output until the Source value output, in seconds. 0 to 655.35 s, 
resolution 0.01 s.
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To Set SMU Outputs (CONST)
Measurement Setup

SMU constant output setup

At the Constants area, you set the SMU constant output.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), or COMMON (ground)

•Base and Source: SMU output value

•Compliance: SMU compliance value

Base value is available for all output channels for the SIMULTANEOUS mode and the last source 
channel for the SEQUENTIAL mode.
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To Set Ranging Mode
Measurement Setup

Fixed range mode

The Range button opens the SMU Range Setup dialog box.  For details of the dialog box, see page 
5-13.

If the range changing occurs during measurement, the SMU may not complete measurement 
within the sampling interval.  So use FIXED range if the sampling interval is top priority and the 
resolution/sensitivity is second priority.
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To Set User Functions/Analysis Functions
Function Setup

Data calculation
-Measurement data/source data
-Built-in function, etc.

Data calculation
-Measurement data/source data
-Read out function
-Built-in function, etc.

Click the Function Setup tab to display the User Function/Analysis Function setup screen.

The user functions can be displayed on the X-Y Graph Plot, List Display, and Parameters area of 
the Data Display window.  Up to 20 functions can be set.

•Name: Function name

•Unit: Unit of the function

•Definition: Definition of the function. The following identifiers can be used.

•Variables for the measurement/output data used in this test

•Functions defined in the above lines

•Local variables passed from the application test that calls this test as a component

•Built-in functions and global variables

For details, see online help or User’s Guide.

The analysis functions can be displayed on the Parameters area of the Data Display window.  Up 
to 20 functions can be set.

•Name: Function name

•Unit: Unit of the function

•Definition: Definition of the function. The following identifiers can be used.

•Variables for the measurement/output data used in this test

•Functions defined in the above lines

•Local variables passed from the application test that calls this test as a component

•Built-in functions and global variables

•Read out functions

For details, see online help or User’s Guide.
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To Set Data Display
Display Setup

Specify X axis and Y axis

Select parameters to display

Select variables to list

Click the Display Setup tab to display the display setup screen. The X-Y Graph area is used to set 
the X axis and Y axis of the X-Y Graph Plot area in the Data Display window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

The List Display area selects the variables to be listed in the List Display area of the Data Display 
window.  Up to 20 variables can be set.

The Parameters area selects the variables to be listed in the Parameters area of the Data Display 
window.  Up to 20 parameters can be set.
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Exercise 8
Define test setup and perform test.

1. Click I/V-t Sampling icon and open setup editor.

2. Define test setup as shown in page 5-27 to 5-32.

3. Save it as Trng Sampling.

4. Connect device (capacitance), and perform test.

5. Export preset group, and import it. 

Time to complete: 10 minutes.

GNDU

SMU5

Note:
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Measurement Result Example

This is a test result example displayed on the Data Display window.
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C-V Sweep Measurement

• To Define Channels and Variables
• To Set Sweep Source
• To Set Signal Source
• To Set Measurement Timing and Abort Function
• To Set SMU Outputs (CONST)
• To Set User Functions/

Analysis Functions
• To Set Data Display
• To Perform Compensation

and Correction

This section explains how to perform C-V sweep measurement.  You will perform the above tasks 
to execute the C-V sweep measurement.
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Channel Setup

Channel Definition
-CMU/SMU
-V name/I name
-I/V/COMMON

Setup Name

Variable name for time stamp data

Variable name for data index

SMU1

SMU3

CML

CMH

To Define Channels and Variables

Click the C-V Sweep icon and open the setup editor.  Then click the Channel Definition tab to 
display the channel definition screen. 

•Enter the Setup Name for the test setup to be defined on the setup editor.

•List units used for source output or measurement, and set the following parameters.

•Unit: MFCMU/SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), or COMMON (ground)

•Time Stamp Name: Variable name for the time stamp data

•Index Name: Variable name for the data index

You can read measurement data by using the Data Display window. Parameters displayed on the 
window are selected on the Display Setup tab screen.  If you enter the variable name in the V 
Name, I Name, Time Stamp Name, and/or Index Name entry fields, you can choose the variables 
as the display parameters.

•The time stamp is the time the measurement is started for each measurement point.

•The index is the index number for each measurement data.
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To Set Sweep Source
Measurement Setup

CV sweep

Start

Stop
Step

The Measurement Setup tab screen is used to set the source output and timing parameters.  

At the C-V area, you set the DC bias output of the MFCMU.

•V Name: Variable name of the MFCMU output

•Model: MFCMU measurement mode. Primary and secondary measurement parameters. Select 
one from the following four models.

•Cp-G: Parallel capacitance (F) and Conductance (S)

•Cp-D: Parallel capacitance (F) and Dissipation factor

•Cs-Rs: Series capacitance (F) and Series resistance (οημ)

•Z-Th: Impedance (οημ) and Phase (degree)

•C/Z Name: Variable name of the primary measurement parameter, C or Z

•G/D/R/Th Name: Variable name of the secondary measurement parameter, G, D, R, or Th

•Direction: Sweep direction, single (start to stop) or double (start to stop to start)

•Start: Source output start value

•Stop: Source output stop value

•Step: Source output incremental step value

•No of Step: Number of sweep steps
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To Set Signal Source
Measurement Setup

At the Signal Source area, you set the MFCMU output frequency and oscillator level.

•Frequency List: MFCMU output frequency

•F Name: Variable name of MFCMU output frequency

•AC Level: MFCMU oscillator level, 10 mV to 250 mV, 1 mV resolution
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To Set Meas. Timing and Abort Function
Measurement Setup Integration time (AUTO or PLC)

Timing parameters

Sweep abort function

Hold time
Delay time

Measurement time

Trigger

CONTINUE AT ANY
STOP AT ANY ABNORMAL
-Range overflow
-MFCMU error
-SMU compliance
-SMU oscillation

At the Integration Time area, you set the integration time of the impedance measurement by the 
MFCMU.

•Mode: AUTO or PLC.  Rule to decide the integration time.  For details, see online help or User’s 
Guide.

•Factor: Coefficient for the reference value of the integration time.

At the Timing area, you set the source output and measurement timing.

•Hold: Source output hold time. Time after the measurement trigger until starting delay time.

•Delay: Measurement start delay time. Time after the hold time until starting measurement.

The Sweep [ ] status field sets the sweep abort function.

When this field is CONTINUE AT ANY, the sweep measurement is not aborted.

When this field is STOP AT ANY ABNORMAL, the sweep measurement will be aborted when one 
of the following conditions is detected.

•Measurement range overflow

•MFCMU error

•SMU compliance

•SMU oscillation
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To Set SMU Outputs (CONST)
Measurement Setup

SMU output setup

At the Constants area, you set the SMU constant output.

•Unit: SMU name or number

•V Name: Variable name for the voltage measurement or source data

•I Name: Variable name for the current measurement or source data

•Mode: Source output mode, V (voltage), I (current), or COMMON (ground)

•Source: SMU output value

•Compliance: SMU compliance value
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To Set User Functions/Analysis Functions
Function Setup

Data calculation
-Measurement data/source data
-Built-in function, etc.

Data calculation
-Measurement data/source data
-Read out function
-Built-in function, etc.

Click the Function Setup tab to display the User Function/Analysis Function setup screen.

The user functions can be displayed on the X-Y Graph Plot, List Display, and Parameters area of 
the Data Display window.  Up to 20 functions can be set.

•Name: Function name

•Unit: Unit of the function

•Definition: Definition of the function. The following identifiers can be used.

•Variables for the measurement/output data used in this test

•Functions defined in the above lines

•Local variables passed from the application test that calls this test as a component

•Built-in functions and global variables

For details, see online help or User’s Guide.

The analysis functions can be displayed on the Parameters area of the Data Display window.  Up 
to 20 functions can be set.

•Name: Function name

•Unit: Unit of the function

•Definition: Definition of the function. The following identifiers can be used.

•Variables for the measurement/output data used in this test

•Functions defined in the above lines

•Local variables passed from the application test that calls this test as a component

•Built-in functions and global variables

•Read out functions

For details, see online help or User’s Guide.



5-43

To Set Data Display
Display Setup

Specify X axis and Y axis

Select parameters to display

Select variables to list

Click the Display Setup tab to display the display setup screen. The X-Y Graph area is used to set 
the X axis and Y axis of the X-Y Graph Plot area in the Data Display window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

The List Display area selects the variables to be listed in the List Display area of the Data Display 
window.  Up to 20 variables can be set.

The Parameters area selects the variables to be listed in the Parameters area of the Data Display 
window.  Up to 20 parameters can be set.
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Calibration button

Advanced Options…

Calibration

To Perform Compensation and Correction

The MFCMU is equipped with the error correction function used to realize accurate impedance 
measurements. The correction function minimizes the effects of the error elements in the 
extension cables and the DUT interface such as manipulator and probe card. 

•Phase compensation: Corrects phase error caused by extending measurement cables.

•Open correction: Corrects for stray admittance. Effective for high impedance measurements.

•Short correction: Corrects for residual impedance. Effective for low impedance measurements.

•Load correction: Corrects any error by using the working standard (load standard).

Click the Calibration button to open the Calibration window.  And click the CMU calibration tab on 
the window to perform the compensation and correction data measurement.

•To measure the phase compensation data, open the measurement terminals at the end of the 
device side and click the Measure... button.

•To measure the open correction data, open the measurement terminals at the end of the device 
side and click the Measure... button.

•To measure the short correction data, connect the measurement terminals together at the end of 
the device side and click the Measure... button.

•To measure the load correction data, connect the load standard that has the reference value or 
calibration value. Then, click the Measure... button.

For details of the error correction (CMU calibration) and the Advanced Options, see online help or 
User’s Guide.  The Advanced Options window is used for the compensation/correction data 
measurement setup.
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Exercise 9
Define test setup and perform test.

1. Click C-V Sweep icon and open setup editor.

2. Define test setup as shown in page 5-36 to 5-42. And 
save it as Trng CV.

3. Open measurement terminals, and perform phase 
compensation and open correction.

4. Connect device, and perform test.

5. Export preset group, and import it. 

Time to complete: 10 minutes.

SMU1

SMU3

CML

CMH

Note:
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Measurement Result Example

This is a test result example displayed on the Data Display window.
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Switching Matrix Control

• To Define Switch Setup

This section explains how to define the switch setup for B2200 Switching Matrix.
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To Define Switch Setup

-Open All
-Switch Setup
-Close Range
-Open Output
-Open Range
-Open Input

Setup Name

-BBM
-MBBR

To specify Input Port

To specify Output Channel

This setup screen is used to create the relay control setup (switch setup) for Agilent 
B2200A/B2201A Switching Matrix.

To send the switch setup to B2200, click the Single button.  Before doing this, you have to 
establish the GPIB connection to B2200 by using the Switching Matrix tab screen of the 
Configuration window.  See Module 8.

This screen provides the following GUI.

Add:  Adds a setup row for relay connection.

Delete:  Deletes the setup row.  To select the setup row, use the left radio button.

Up:  Moves the selected setup row upward.

Down:  Moves the selected setup row downward.  The setup row provides the following entry 
fields.

Operation:  Relay control operation.  Open All, Switch Setup, Close Range, Open Output, Open 
Range, or Open Input.  See the next page.

Input:  B2200 input port number or label.  Available for the Switch Setup, Close Range, and Open 
Input operations.

Outputs:  B2200 output channel number or label.  Four entry fields are available for the Switch 
Setup and Open Output operations to specify the output channels. Two entry fields are available 
for the Close Range and Open Range operations to specify the range of output channels.

Rule:  Relay connection rule.  BBM or MBBR.

•BBM: Breaks the previous connection and then makes the new connection for the specified 
outputs.

•MBBR: Makes the new connection and then breaks the previous connection for the specified 
outputs.
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Operation and number of Outputs

Opens the relays connected to the specified input port.

Opens the relays connected to the specified output 
channels.  They are between two channels given by 
the Outputs fields.

Opens the relays connected to the specified output 
channels.  Up to four output channels can be specified 
at once.

Makes the connection from the specified input port to 
the specified output channels.  They are between two 
channels given by the Outputs fields.

Makes the connection from the specified input port to 
the specified output channels.  Up to four output 
channels can be specified at once.

Opens all relays.

Description

0

2

4

2

4
0

Number of 
Outputs

Open Input

Open Range

Open Output

Close Range

Switch Setup
Open All

Operation

Note:
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Exercise 10
Define switch setup and send it to B2200.

1. Click Switching Matrix Control icon and open setup 
editor.

2. Define switch setup as you want. And save it as 
Trng Switch.

3. If B2200 is available, establish the GPIB connection 
between B1500 and B2200, and apply your switch 
setup.

Time to complete: 5 minutes.

Note:
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Module 6. Creating Your Test Definitions
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In This Module

• What is Test Definition
• What is Test Contents
• To Open Test Definition Editor
• To Define Test Specification
• To Define Test Contents
• To Save and Close Your Test Definition
• To Export/Import Test Definition
• If You Define Application Test Output

This section explains how to create your test definition.  You will perform the above tasks to 
create the definition.
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What is Test Definition

Test Specification Test Output

Test Contents

•Test name
•Test description
•Variables

•Entry fields

•Variables

•Test result display

•Local variables
•Test execution flow
•Test setup

•Device parameters
•Test parameters

•X-Y graph
•Data list
•Parameter display

•Classic test
•Application test
•My Favorite setup

•Analysis parameters

Test definition consists of test specification, test contents, and test output setup.  The test 
specification contains test name, description, device parameters, and test parameters.  The 
parameters will be the variables used to pass the test conditions to the test execution flow or test 
setup defined in the test contents.  Especially for the test parameters, you can specify the 
position of entry field for each parameter.  You can see the entry fields when the main screen 
displays this application test setup.  The test contents are the core of the test definition.  You will 
define the local variables, test execution flow, and test setup. You can define the test setup by 
selecting application tests, classic tests, or my favorite setup, and entering the test conditions.  

The test output setup is optional.  If you need the test result output (test result display and 
record) of the test definition, declare the variables (analysis parameters) and define the display 
parameters.  See “If You Define Application Test Output”.

You can use the device parameters, test parameters, and analysis parameters in the test 
execution flow (program flow) of the test contents without declaration of local variables.
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What is Test Contents

Variables
•Device parameters
•Test parameters

Variables
•Analysis parameters

Local variables

Program Component

Application Test

Classic Test

Analysis

Miscellaneous

Test OutputTest Specification

My Favorite

Test contents are the test execution flow (program flow), and is the core of the test definition.  In 
the test contents, the following elements can be defined.

•Local variables

•Program components

•Application tests

•Classic tests

•My Favorite setup

•Analysis components

•Miscellaneous components

•Device parameters defined in the test specification

•Test parameters defined in the test specification

•Analysis parameters defined in the test output

The program is executed from top to bottom in the test execution program list.
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To Open Test Definition Editor

Define New Test…

To start test definition, open the test definition editor.

Select the Application Test tab, click the Library button, and select the Define New Test…
function.  The test definition editor will be opened.  See next slide.
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To Define Test Specification

Set test information

Define device parameters

Set properties 
of parameter

The test definition editor provides three tabs, Test Specification, Test Contents, and Test Output.  
At first define the test specification.  Click the Test Specification tab.

In the Test Information area:

•Click the right button in the Category field to specify the category the new test definition 
belongs.

•Enter the Test Name.

•Select the Icon that will be displayed on the list area below the Library button of the main 
screen.  It is the image file used to select the test definition.  See previous slide.

•Enter the Description of the test.

In the Device Parameters Definition area:

•Click Add button to display the entry fields for the parameter.

•Set the Name, Default value, and Description for the parameter. When you add a parameter, you 
will see the entry fields at the Properties area.  The area shows you the properties (minimum 
value, maximum value, number of effective digits, resolution, and unit) for the device parameter or 
the test parameter specified by the radio button put on the left of the parameter name.

For the Typical Values… button and the Symbols… button, see online help or User’s Guide.
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To Define Test Specification

Define test parameters

Set properties 
of parameter

In the Test Parameters Definition area:

•Select the Background that will be displayed on the application test setup area of the main 
screen.  Usually it is the image that shows the device connections.

•Set the Name, data type, Default value, and Description for the parameter.  When you add a 
parameter, you will see the entry fields at the Properties area. The area shows you the properties 
(minimum value, maximum value, number of effective digits, resolution, and unit) for the device 
parameter or the test parameter specified by the radio button put on the left of the parameter 
name.

•Set the X, Y, and Width values to specify the position of entry field displayed on the application 
test setup area.  

•Check the Aligh box to set the X origin of entry field to the left edge of the entry field.  Uncheck 
this box to set it to the left edge of the parameter name placed left next to the entry field.

•Check the Ext box.  The entry field will be put on the Extended Test Parameters dialog box that is 
displayed by clicking the Extended Setup button on the application test setup area of the main 
screen. 
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Setup example
Test Specification

This example sets:

Category: TRNG (newly created)

Test Name: Trng idvd idvg

Icon: IdVg.bmp

Device parameters:

Hold and Delay

Background: Vth_gmmax.PNG

Test parameters:

Drain, Gate, Source, Subs
IdVd_Vdstart, IdVd_Vdstop, IdVd_step, IdVd_Vgstart, IdVd_Vg_nop, IdVd_Vgstep

IdVg_Vdout, IdVg_Vgstart, IdVg_Vgstop, IdVg_Vgstep

Vsub, Vs, Icomp, Igcomp

Entry field properties: 80 (width) x 30 (distance in vertical direction)
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Result example
Parameter entry fields

This is a result example of the test specification setup shown in the previous slide.
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To Define Test Contents

Select available element

Specify the line 
to insert element 
or edit

Click available 
button

Define the setup necessary 
for the highlighted element

Define the test contents as shown below:

•Click the Test Contents tab.

•Click the Local Variable Definition line to highlight the line. The right open space displays the 
Local Variables Definition statement setup editor.

•Define the local variables used in this test execution flow (program flow).

•Click the line that an element has to be inserted.

•Click an element of Program Component, Application Test, Analysis, Classic Test, or 
Miscellaneous tab menu.

•Click the Insert button of the Edit tab menu.  The element will be inserted between the 
highlighted line and the next line.

•Repeat this to create the test execution flow.
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Available elements

Program Component

Application Test

Analysis

Classic Test

Miscellaneous

My Favorite

Available elements are shown above.  The Program Component provides the typical program 
statements such as IF, LOOP, FOR, and so on.  They are used to control the test execution flow.  
The Application Test, Classic Test, and My Favorite are used to define the test setup/test 
condition.  The Analysis provides the elements used to control auto analysis function and data 
display.  And the Miscellaneous provides other useful elements. For details of elements, see 
online help or user’s guide.
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Defining Local Variables
Local Variables Definition

Add Numeric Variable button displays the Numeric Variable area that provides the following 
fields.

•Name: Numeric variable name

•Value: Initial value of the variable

•Description: Additional information for the variable

Add Vector Variable button displays the Vector Variable area that provides the following fields.

•Name: Vector variable name. Two dimensional array.

•Count: Number of elements, or array size

•Description: Additional information for the variable

This area also provides the following radio button used to specify how to set the initial value of 
the array data automatically.

• Assign Linear Values FROM [value of first element] TO [value of last element]

If Count>1, this sets first value + (N-1) x (last value-first value)/(Count-1) to the N-th element. If 
Count=1, this sets first value(=last value) to the element.

• Assign Linear Values FROM [value of first element] STEP [step value]

This sets first value + (N-1) x step to the N-th element.

Add String Variable button displays the String Variable area that provides the following fields.

•Name: String variable name

•Value: Initial value of the variable

•Description: Additional information for the variable

Add Module Variable button displays the Module Variable area that provides the following fields.

•Name: Module variable name

•Description: Additional information for the variable



6-13

Editing test contents

•Block Selection
•Insert
•Delete
•Copy
•Cut
•Paste 

The Edit tab provides the following buttons:

•Block Selection/Line Selection toggle button selects the edit target selection mode.  In the line 
selection mode, clicking line just selects the line.  In the block selection mode, clicking line 
selects the block the line belongs.

•Insert button inserts the specified element between the highlighted line and the next line.

•Delete button deletes the highlighted line.

•Copy button copies the highlighted line to the clipboard.

•Cut button moves the highlighted line to the clipboard.

•Paste button inserts the line in the clipboard between the highlighted line and the next line.
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Debugging test contents

•Run
•Abort
•Stop
•Break
•Inspect 

The Debug tab menu provides the following buttons:

•Run button starts the debug (executes the test flow).  During execution, the label changes to 
Pause.  Clicking Pause button pauses the execution, and changes the label to Run that is used to 
continue the debug (execution).

•Abort button aborts the debug (execution).

•Step button executes the highlighted line of the test flow.  Clicking the button repeatedly 
continues the execution by a line.

•Break button sets/releases the break point.  For the break point, this button releases the break 
point from the highlighted line.  Program execution will break at the break point automatically.

•Inspect button is available when the debug (execution) is paused or breaked.  This button opens 
the Variable Inspector used to monitor value of device parameters, test parameters, analysis 
parameters, local variables, or system variables.
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Monitoring Variable Values
Debug: Inspect button

Break point

Paused point

The Variable Inspector is displayed by clicking the Inspect button after the program is paused, and 
is used to monitor or change the value of the device parameters, test parameters, analysis 
parameters, local variables, or system variables.  For the vector variables, only data monitor is 
available. The Variable Inspector provides the following buttons to add the variable monitor area.

• Add Numeric Variable

• Add Vector Variable

• Add String Variable

• Add Module Variable

The following functions are available for the menu displayed by clicking the banner of the variable 
monitor area.

•Up: This button shifts the variable monitor area upward.

•Down: This button shifts the variable monitor area downward.

•Remove: This button deletes the variable monitor area.
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Available variables

Test Specification
•Device parameters
•Test parameters

Test Output
•Analysis parameters You can connect the 

variables in test setup with
•Local variables
•Device parameters
•Test parameters
•Analysis parameters 

Test Contents
•Local variables

Assign to external variables…

Do not set the same name for 
variables and parameters.  
The name must be unique.

In the test execution flow (program flow), you can use the following variables.

•Local variables defined in the test contents

•Device parameters defined in the test specification

•Test parameters defined in the test specification

•Analysis parameters defined in the test output

You need to declare the variables used in the test contents definition by using the Local Variables 
Definition.  You can use the device parameters, test parameters, and analysis parameters without 
declaration of local variables.

You can read the value of parameters/variables used in the Application Test setup or Classic Test 
setup defined in a test contents.  To do so, use the External Variables Setup dialog box or built-in 
functions.  The read values can be used for the calculation of test result and the display and 
record of calculation result. See “If You Define Application Test Output”.
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To Save and Close Your Test Definition
Close Test Definition editor, and save your test definition

Save   Ctrl+S
Close

Test Definition editor

After you create your test definition, save the definition and close the Test Definition editor.

Select File/Close menu.  Confirm Test Definition Save dialog box is opened.  Click Yes to save 
your test definition and continue the close operation.

If the same file name exists, the Confirm Test Definition Overwrite dialog box is opened.  Click OK 
to overwrite your test definition.
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To Export/Import Test Definition
Click Library/Export Test Definition or Import Test Definition

Cancel
Define New Test…
Open Definition of This Test…
Delete Definition of This Test
Import Test Definition…
Export Test Definition…

The test definition can be exported as the EasyEXPERT test definition file format or XML file 
format.  And the file can be imported to the EasyEXPERT later.
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Exercise 11
Define test definition and perform test.

1. Open test definition editor.

2. See setup examples and define your test definition.

3. Save the definition as Trng idvd idvg.

4. Connect device, and perform test.

5. Export your test definition, and import it. 

Time to complete: 10 minutes.

SMU1

SMU3

SMU4

SMU2

Note:
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Measurement Result Example

This is a test result example displayed on the Data Display window.
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If You Define Application Test Output

• Defining Test Output
Step 1. To define analysis parameters
Step 2. To set display parameters

• Reading test setup internal parameters
Case 1. To use External Variables Setup dialog box
Case 2. To use built-in functions

If you want to get the output of the application definition, define analysis parameters and set 
display parameters in the Test Output tab screen.  See the following pages.

You can read the value of parameters/variables used in the Application Test setup or Classic Test 
setup defined in a test contents.  To do so, use the External Variables Setup dialog box or built-in 
functions.  The read values can be used for the calculation of test result and the display and 
record of calculation result.
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Defining Test Output

Specify X axis and Y axis

Select variables to list

Opens Analysis Parameter 
Definition window 
(see next slide).

Select parameters 
to display

1. Define analysis parameters.
2. Set display parameters.

The test output setup is optional.  If you need the test result output (test result display and 
record) for this application test, declare the variables (analysis parameters) and define the display 
setup.

At first, declare the analysis parameters:

•Check the Define own Output Parameters box.

•Click the Define Analysis Parameters… button.  The Analysis Parameter Definition window is 
opened.

•Declare the analysis parameters.  See next slide.

•Click the Close button.

•Set the display parameters.  See below.

The X-Y Graph area is used to set the X axis and Y axis of the X-Y Graph Plot area on the Data 
Display window.

•Name: Name of variable to plot on the X axis

•Scale: Linear or Log

•Min: Minimum value of the specified axis

•Max: Maximum value of the specified axis

The List Display area selects the variables to be listed on the List Display area of the Data Display 
window.  Up to 20 variables can be set.

The Parameters area selects the variables to be listed on the Parameters area of the Data Display 
window.  Up to 20 parameters can be set.
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Step 1. To define analysis parameters
Define Analysis Parameters…

Declare the analysis parameters as shown below:

At the Vector Parameters area or the Scalar Parameters area:

•Click the Add button.

•Enter the Name, Unit, and Description of the parameter.

For the sweep output/measurement data, use the vector parameter.

For the spot output/measurement data, use the scalar parameter.

For the data given by the max( ) and min( ) built-in function, use the vector parameter.

In this example, VG, ID, and GM are the vector parameter and VTH is the scalar parameter. 
GM_MAX is the vector parameter because the max( ) built-in function is used to calculate this 
value.
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Step 2. To set display parameters

This example sets:

X-Y Graph: ID-VG plot for Y1-X graph and GM-VG plot for Y2-X graph

List Display: VG, ID, and GM

Parameters: GM_MAX and VTH

All parameters must be declared by using the Analysis Parameter Definition window shown in the 
previous slide or displayed on the last data display.
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Reading test setup internal parameters
Case 1. To use External Variable Setup dialog box

From Classic Test,
Display Setup screen

Assign to external variables…

External Variable Setup

•Local variable
•Device parameter
•Test parameter
•Analysis parameter

Internal variable

From Application Test setup

Assign to external variables…

To read the value of variables used in an Application Test setup or a Classic Test setup, make a 
mapping table between the test setup internal variables and the external variables which mean 
the local variables, device parameters, test parameters, and analysis parameters defined in the 
test contents.

To open the External Variable Setup window from a classic test setup:

•Specify the classic test.

•Click the Display Setup tab.

•Click the Assign to external variables… button.

To open the External Variable Setup window from an application test setup:

•Specify the application test.

•Click the Assign to external variables… button.
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Setup example
Assign to external variables…

This example makes the mapping table between the test setup internal parameters and the 
analysis parameters. 

•Define VTH, GM_MAX, VG, ID, and GM as the analysis parameters.

•Set these analysis parameters to the display parameters.

•Open the External Variable Setup dialog box.

•Match VTH with the internal parameter Vth.

•Match GM_MAX with the internal parameter gmMax.

•Match VG with the internal parameter Vgate. 

•Match ID with the internal parameter Idrain.

•Match GM with the internal parameter gm. 
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Result example
Data Display window

This is a result example of the test output setup shown in the previous pages.
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Reading test setup internal parameters
Case 2. To use built-in functions
Local Variables Definition
BLOCK

IdVg
VG = getVectorData(“Vg”)
ID = getVectorData(“Id”)
GM = getVectorData(“gm”)
GM_MAX = getVectorData(“gmMax”)
VTH = getNumericData(“Vth”)
IdVd

END BLOCK

Vg, Id, gm, gmMax, and Vth
must be the display parameters 
of IdVg.

Display parameters of
the last Data Display window

Test setup

Test setup

This example shows another way to read the value of the internal variables (Vg, Id, gm, gmMax, 
and Vth).  In this example, you do not use the mapping table but use the getVectorData and 
getNumericData built-in functions.  The functions can be used to read the value of parameters 
displayed on the last data display. 

To read the value:

•Define VG, ID, GM, GM_MAX, and VTH as the analysis parameters.

•Set these analysis parameters to the display parameters.

•Insert the ASSIGN statements to add the formula shown above. 
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Setup example
Test Contents

This example sets the following test flow:

Local Variables Definition    ! Defiles Yes variable

BLOCK

Message    ! Do you perform Id-Vg measurement?

IF Yes=1

IdVg   ! Classic test setup for Id-Vg measurement

VG=getVectorData(“Vg”)

ID=getVectorData(“Id”)

GM=getVectorData(“gm”)

GM_MAX=getVectorData(“gmMax”)

VTH=getNumericData(“Vth”)

END IF

Message    ! Do you perform Id-Vd measurement?

IF Yes=1 

IdVd    ! Classic test setup for Id-Vd measurement

END IF

Message    ! Click OK to display VTH and GM_MAX values and end the test

END BLOCK
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Result example
Data Display window

This is a result example of the test output setup shown in the previous pages.
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Module 7. Advanced Definitions and Operations
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In This Module

• To Control External GPIB Devices
• To Call Execution Files
• To Perform Repeat Measurements
• Prober Control Script



7-3

To Control External GPIB Devices
Miscellaneous: GPIB I/O

Write String to send a string command to GPIB device
Write Value to send a command to GPIB device
Read String to read a string value from GPIB device
Read Value to read a numeric value data from GPIB device
Read List to read a vector data from GPIB device
Read STB to read status byte of GPIB device
GP-IB Control Group Execution Trigger

Device Clear
Go To Local
Local LockOut

You can control external GPIB devices from the EasyEXPERT by using the GPIB I/O statement.  
The GPIB I/O statement provides the write/read functions shown above.  Select a write function 
and enter the necessary parameters to send a command to the GPIB device.  Select a read 
function and enter the necessary parameters to read response from the GPIB device.  For details, 
see online help or User’s Guide.

The followings are the GPIB Control functions.

•Group Execution Trigger: Sends a trigger to the specified GPIB device.

•Device Clear: Sends a device clear to the specified GPIB device.

•Go To Local: Returns the specified GPIB device to the local state.

•Local LockOut: Locks the specified GPIB device.

Note:
Before starting, enable System Controller.  See Module 8.  Also establish the GPIB connection 
with the external GPIB devices.



7-4

To Control External GPIB Devices
Agilent B2200 control example
To send command

Value 1
Value 2
Value 3
Value 4

{0}
{1}
{2}
{3}

Programming image:

*RST
:ROUT:FUNC ACON
(enters “SMU1” to StringPort)
:ROUT:SYMB:PORT {0},”{1}”
:ROUT:SYMB:PORT? {0}
(reads string data)
*OPC?
(reads operation complete flag)
(enters “OUT1” to StringCh)
:ROUT:SYMB:CHAN {0},{2},”{1}”
:ROUT:SYMB:CHAN? {0},{2}
(reads string data)
*OPC?
(reads operation complete flag)

This slide shows an example setup of the GPIB I/O statement.  This is a component of the test 
contents used to control the Agilent B2200 switching matrix.

This example uses the Write Value function to send the following command to the B2200.

:ROUT:SYMB:CHAN {0},{2},”{1}”

where, {0} is CardNo, {1} is StringCh, and {2} is ChanNo.

The followings are the reference of the setup editor.

•Address: GPIB address of the device

•Terminator: EOI, LF, CR/LF, LF+EOI, CR/LF+EOI, or NONE (no terminator)

•Format: Command (header and parameters) sent to the device

•Value 1: Value for {0}

•Value 2: Value for {1}

•Value 3: Value for {2}

•Value 4: Value for {3}

{0}. {1}, {2}, and {3} are variable available in the Format field only.

Note:
Use double quotes to enter a string to a local variable by using the Assign statement.
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To Control External GPIB Devices
Agilent B2200 control example
To read data

Programming image:

*RST
:ROUT:FUNC ACON
(enters “SMU1” to StringPort)
:ROUT:SYMB:PORT {0},”{1}”
:ROUT:SYMB:PORT? {0}
(reads string data)
*OPC?
(reads operation complete flag)
(enters “OUT1” to StringCh)
:ROUT:SYMB:CHAN {0},{2},”{1}”
:ROUT:SYMB:CHAN? {0},{2}
(reads string data)
*OPC?
(reads operation complete flag)

This example uses the Read String function to read the response from the B2200.  This example 
reads the :ROUT:SYMB:CHAN? query command response.  The result (ReturnCh value) must be 
OUT1.
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To Call Execution Files
Miscellaneous: Command Execution

Specifies variables used to receive execution 
results or output data.  This area is deleted by 
Read Type: None.

Specifies vector variable  or 
string sent to the exe file.

You can call the execution file (EXE file) from the EasyEXPERT.  Use the Command Execution 
statement and define the setup editor as shown in this example.

•Command Filename:  Execution file name (command name)

•Argument:  Command parameter or argument

•Write Type:  String or List (vector data)

•Read Type:  String, Value (numeric data), List (vector data), or None (no read data)

If you specify Write String, enter the string sent to the command.

If you specify Write List, enter the name of vector variable sent to the command, and specify the 
format of data element sent to the command.  See next slide.

In the Read String/Value/List area, specify the variables used to receive execution result and 
output data.  There is no entry field for Read Type: None.

•Result:  Numeric variable name.  Used to store the execution result.

•Value:  Numeric variable name for Read Value, or vector variable name for Read List.  Used to 
store the returned data.

•String:  String variable name.  Used to store the returned data.

•Length Actually Read:  Numeric variable name.  Used to store the byte length of the returned 
data.

The above example calls the sleep.exe file used to insert the wait time for program execution.  
The WAIT value must be defined in msec.  After the normal command execution, the sleep.exe 
returns 1 for Value and 0 for Result.  The sleep.exe file is stored in the following folder.

C:\Program Files\Agilent\B1500A\EasyEXPERT\Utilities
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To set Format field

{I[,A][:F]}
• I List data index.  Or index of element.  Integer.
• [,A] Character length of the specified data element.

Positive integer for right-aligned, or negative
integer for left-aligned.  Optional.

• [:F] Format identifier.  C, D, E, F, G, N, P, R, or X. 
Lower case is available.  Optional.

Example: 
{0,5:E} First element, 5 characters, exponential notation.
{1:G} Second element, general.
{2,10} Third element, 10 characters, general.

The Format field is used to specify the data format of List (vector variable).  The strings shown in 
the above example can be defined in the Format field.

In the strings, the list data index is mandatory.  The character length and format identifier are 
omissible.  Then the length is not limited, and the format G is set.

C or c:  Circulation

D or d:  Decimal numeral

E or e:  Exponential notation

F or f:  Fixed point

G or g:  General

N or n:  Numeric

P or p:  Percent

R or r:  Round trip

X or x:  Hexadecimal numeral

For the format, see online help or manual of the Agilent T&M Programmers Toolkit.
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Exercise 12
Try to improve your test definition as you want.

• To Use Built-in Functions
• To Use Read Out Functions
• To Control External GPIB Devices
• To Call Execution Files

Note:
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To Perform Repeat Measurements

If Abort is clicked

No

Start (Run)

Start Procedure

Yes

Iteration Procedure

Final Procedure

End

Test Execution

Yes

No

status= 0 ?

No

Yes
Count < limit

status= 0 ?

Count=Count+1

Count=0

A

C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities

C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities

C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities

Abort5     

status limit

Repeat measurement is performed as shown in this flowchart.  The status is a response returned 
by the start/iteration procedure. The Count is the accumulated number of test executions.  They 
are the stop condition of the repeat measurement.

The repeat measurement stop function is enabled by the following check boxes.

•Counter reaching to

•Procedure return condition

If the first box is checked and the limit value is specified, the repeat measurement will be stopped 
if Count >= limit.  To perform the repeat measurement, set the limit value more than the number 
of devices under test or remove check from this box.

If the second box is checked, the repeat measurement will be stopped if status is not 0.

When the second box is checked, the device ID automatic setup function is available and is 
enabled/disabled by using the following check box.  The function enters the device_id value to 
the Device ID of the test result record.  The device_id is a response returned by the 
start/iteration/subsite procedure.

•Automatically fill in Device ID

The Repeat Measurement Setup dialog box provides the following action buttons.

•Run: Starts repeat measurement.

•Abort: Stops repeat measurement immediately.

•Cancel: Closes the Repeat Measurement Setup dialog box.

Start/Iteration/Final Procedure:
Enter the full path name of the procedure.  For example, enter as follows.
C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities\ProberControl\suss\Start_suss.exe

Arguments:
Enter the options of the procedure.  See the following pages describing about procedures.  For 
example, enter –a GPIB0::5::INSTR –l C:\temp\prb.log.

If you use the sub die move operation (subsite procedure), the flowchart must be changed.  See 
page 7-18.
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Subsite move Test Setup

Select

Specify ProberType.
Or specify driver for your prober in CustomProber.

Save

If you do not use the sub die (subsite) move operation, skip this page.

Click Application Test tab and open the Subsite move test setup in the Utility category.  On the 
Subsite move setup screen, specify ProberType (Cascade, Suss, or Vector) or driver for your 
prober in CustomerProber, and save it as a setup in your preset group (My Favorite Setup).  Then 
you can use the setup for your quick test.  See next page.

The Subsite move setup moves wafer chuck to the next subsite, reads device ID from the prober, 
and sets it to the Device ID of the test result record. 

For more details of the test setup, open the Test Definition window.

In the Subsite move test definition, an execution file callProbeDvr.exe is used.  This file is used to 
send Subsite_xxxx.exe to the prober specified by the prober_info.ini file and receive the response; 
status and device_id.  The callProberDvr.exe has the following input/output parameters.

Input: Full path of Subsite_xxxx.exe

Output: status; 0 (no error) or 1 (error)

Output: device_id

Note:
The callProberDvr.exe refers to the prober_info.ini file for the GPIB address and log file name.  Do 
not set the Arguments of Subsite_xxxx.exe.
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To Use Subsite move

C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities

C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities

C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities

5

If you do not use the sub die (subsite) move operation, skip this page.

To perform the test with the sub die move operation, do as follows.

1. Add the Subsite move test setup to your preset group (My Favorite setup).

2. Set your preset group and test setups in the Quick Test tab screen.

3. Open the Repeat Measurement Setup dialog box.

4. Specify the procedures and the repeat measurement condition.

5. Start repeat measurement.

The Subsite move setup must be entered after measurements for a sub die.
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Prober Control Script
• Prober information file

prober_info.ini
• Start Procedure

Start_xxxx.exe
• Iteration Procedure 

Iterator_xxxx.exe
• Final Procedure 

Final_xxxx.exe
• Subsite Procedure

Subsite_xxxx.exe

xxxx: • cascade
• suss
• vector

Use prober control script in EasyEXPERT
Repeat Measurement Setup window

Prober control script is sample program used for semi-automatic prober control. The Agilent 
EasyEXPERT can call the script by using the Repeat Measurement Setup window.

See page 7-9 to call the script and perform repeat measurement.

See page 7-14 for the prober information file.

See page 7-13 for the start procedure.

See page 7-15 for the iteration procedure.

See page 7-16 for the final procedure. 

See page 7-17 for the subsite procedure.

To use the prober control script, specify the start/iteration/final procedure in the Repeat 
Measurement Setup dialog box (see page 7-9).  And use the Subsite move test setup in your 
quick test to control sub die move.  The Subsite move setup uses the subsite procedure for 
moving wafer chuck to the next subsite.  See page 7-10 and 7-11.
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Start_xxxx.exe
• Arguments: -a GPIB_address

-l log_file_name
Example:
–a GPIB0::5::INSTR –l C:\temp\prb.log

• Response: XML format data

status: 0 (no error) or 1
device_id: prefix:coordinate

Example:

<Response>
<Break>status</Break>
<Target>device_id</Target>

</Response>

<Response>
<Break>0</Break>
<Target>waf1a:3 1</Target>

</Response>

Start

End

Displays Device ID Entry dialog box 

Moves to the first position

Gets X-Y coordinate

Chuck up

Returns response

Updates prober_info.ini file

Displays Start Confirmation dialog box

Yes

No

YesProber error?
No

Prober error?

B

To specify the start procedure in the Repeat Measurement Setup dialog box, enter the full path 
name of Start_xxxx.exe into the Start Procedure field.

After the repeat measurement is started, this procedure displays the Device ID Entry dialog box 
and waits for your input.  On the dialog box, enter a string used for the prefix of device_id.  After 
that, you will see the Start Confirmation dialog box that is used to confirm your wafer setup 
status.  Load wafer and perform wafer alignment, then click OK on the dialog box. The procedure 
moves wafer chuck to the first probing position, checks the prober status, gets the X-Y coordinate 
of the probing position, and sets the wafer chuck to the UP position.  At last, the procedure 
returns the response.

The status is 0 or 1. It is used for the EasyEXPERT repeat measurement stop function.  When the 
Procedure return condition box is checked in the Repeat Measurement Setup dialog box, the 
repeat measurement will be stopped if status is not 0.

The device_id is a string for the Device ID of the test result record.  When the Automatically fill in 
Device ID box is checked in the Repeat Measurement Setup dialog box, the device_id will be 
entered to the Device ID of the test result record.

If you use the subsite procedure, the flowchart must be changed.  See page 7-18.

Note:
To ignore the Arguments, set the GPIB address and log file name in the prober_info.ini.
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Prober_info.ini

[Prober]
Address=GPIB::5::INSTR 
LogMode=True
LogName=C:\temp\prb.log

[Target]
UseID=True
SubsiteInfo=False
WaferInfo=False
ID=waf1a

<Response>
<Break>0</Break> 
<Target>waf1a:4 1</Target>

</Response>

device_id = prefix:coordinate

GPIB address of prober

Full path name of log file

Prefix you enter in the Device ID Entry dialog box.
ID is automatically recorded in the prober_info.ini file. 
The Device ID Entry dialog box is opened by Start_xxxx.exe.

The prober information file is necessary to execute the prober control script.  Before starting 
tests, open this file, edit it as you want, and overwrite it.  The name must be prober_info.ini.

The prober_info.ini file stores the information shown below.

•Address: GPIB address of prober

•LogMode: Log file creation mode; True or False

•LogName: Log file name (full path)

•UseID: Device ID creation mode; True or False

•SubsiteInfo: Set always False. This is just a place holder.

•WaferInfo: Set always False. This is just a place holder.

•ID: Ignore this variable. This is just a pass parameter.

If the procedures specify the –a option, the Address value is not used.

If the procedures specify the –l option, the LogName value is not used. 

To create a log file, set LogMode=True.

To use the prefix:coordinate format for the device_id value, set UseID=True.  If UseID=False, the 
device_id value will be coordinate, not prefix:coordinate.  The prefix will be the value entered in 
the Device ID Entry dialog box that is opened by Start_xxxx.exe.  This function is available when 
the Automatically fill in Device ID check box is checked.
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Iterator_xxxx.exe
• Arguments: -a GPIB_address

-l log_file_name
Example:
–a GPIB0::5::INSTR –l C:\temp\prb.log

• Response: XML format data

status: 0 (no error) or 1
device_id: prefix:coordinate

Example:

<Response>
<Break>status</Break>
<Target>device_id</Target>

</Response>

<Response>
<Break>0</Break>
<Target>waf1a:4 1</Target>

</Response>

Start

End

Chuck down

Moves to the next position

Chuck up

Returns response

Yes

YesProber error?
No

Prober error?

Yes

No

Prober error?

Gets X-Y coordinate
No

B

To specify the iteration procedure in the Repeat Measurement Setup dialog box, enter the full 
path name of Iterator_xxxx.exe into the Iteration Procedure field. 

The procedure is called after the measurement is completed for a die.  This procedure sets wafer 
chuck to the DOWN position, moves it to the next probing position, checks the prober status, gets 
the X-Y coordinate of the probing position, and sets the wafer chuck to the UP position.  At last, 
the procedure returns the response.

The status is 0 or 1. It is used for the EasyEXPERT repeat measurement stop function. When the 
Procedure return condition box is checked in the Repeat Measurement Setup dialog box, the 
repeat measurement will be stopped if status is not 0.

The device_id is a string for the Device ID of the test result record.  When the Automatically fill in 
Device ID box is checked in the Repeat Measurement Setup dialog box, the device_id will be 
entered to the Device ID of the test result record.

If you use the subsite procedure, the flowchart must be changed.  See page 7-18.

Note:
To ignore the Arguments, set the GPIB address and log file name in the prober_info.ini.
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Final_xxxx.exe

Start

End

Chuck down

• Arguments: -a GPIB_address
-l log_file_name

Example:
–a GPIB0::5::INSTR –l C:\temp\prb.log

• Response: none

C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities

C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities

C:\Program Files\Agilent\B1500\EasyEXPERT\Utilities

5Stop condition

To specify the final procedure on the Repeat Measurement Setup dialog box, enter the full path 
name of Final_xxxx.exe into the Final Procedure field.

The procedure is called after one of the stop condition is detected.  This procedure sets wafer 
chuck to the DOWN position.

Note:
To ignore the Arguments, set the GPIB address and log file name in the prober_info.ini.
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Subsite_xxxx.exe
Start

End

Chuck down

Moves to the next subsite

Chuck up

Returns response

YesProber error?

Yes

No

Prober error?

Gets X-Y coordinate
No

• Arguments: -a GPIB_address
-l log_file_name

Example:
–a GPIB0::5::INSTR –l C:\temp\prb.log

• Response: XML format data

status: 0 (no error) or 1
device_id: prefix:coordinate

Example:

<Response>
<Break>status</Break>
<Target>device_id</Target>

</Response>

<Response>
<Break>0</Break>
<Target>waf1a:3 1</Target>

</Response>

To realize sub die move operation, you need to define Subsite_xxxx.exe in your test definition and 
create your application test setup.  However, you do not need to take care of this procedure by 
using the Subsite move test setup included in the application library.  The Subsite move setup 
moves wafer chuck to the next subsite, reads device ID from the prober, and sets it to the Device 
ID of the test result record.

Open the Subsite move test setup and save it as a setup in your preset group (My Favorite Setup).  
Then you can use the setup for your quick test.  

Note:
To use the Subsite move setup, set the GPIB address and log file name in the prober_info.ini.  
And ignore the Arguments for Subsite_xxxx.exe.

Note:
If you use a Suss prober, the number of Subsite move setups used in your quick test (die test) is 
important.  It must be N-1; N is the number of subsites defined in the prober.

The status is 0 or 1.  It is used for the EasyEXPERT repeat measurement stop function.  When the 
Procedure return condition box is checked in the Repeat Measurement Setup dialog box, the 
repeat measurement will be stopped if status is not 0.

The device_id is a string for the Device ID of the test result record. 
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To Change Execution Flow

A
Subsite Procedure

Yes

No
status= 0 ?

Test Execution

B Move to the 1st subsite

If you use the subsite procedure, change the flowchart as follows.
On the page 7-9, replace the box A with the block A shown above.
On the page 7-13 and 7-15, insert the box B shown above to the position B of the flowchart.
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Module 8. Miscellaneous Operations
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In This Module

• Function Status Indicator
• Automatic Data Export and Data Record
• Calibration
• Configuration
• XSLT Samples
• To Enable System Controller
• To Start Desktop EasyEXPERT
• To Use Setup File Converter

This module describes the above topics.  You will understand what is the status indicator, what is 
the automatic data export function and the automatic data record function, how to perform 
selftest and calibration, how to perform SMU zero offset cancel, and so on.



8-3

Function Status Indicator

Automatic data export OFF

Automatic data record ON

ON

ON

OFF

SMU zero offset cancel OFF

Status indicator lets you know the status OFF or ON of the following functions.  The indicators are 
placed at the bottom of the main screen.

SMU Zero OFF/ON: Shows the status of the SMU zero offset cancel function OFF or ON.

Auto EXPORT OFF/ON: Shows the status of the automatic data export function OFF or ON.

Auto Record ON/OFF:  Shows the status of the automatic data record ON or OFF.

The functions can be set to ON or OFF as shown in the following pages.
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Automatic Data Export and Data Record

The automatic data export function and the automatic data record function can be enabled or 
disabled by using the Test Results Data Auto Export dialog box. This dialog box is displayed by 
selecting the Results > Transport Data > Auto Export Setting… menu.

The automatic data export function is used to export the test result data to the storage device you 
specify.  You can specify the destination (storage device), exported file name, and file type.  To set 
the automatic data export function to ON, check the Enable automatic data export to the specified 
storage device check box.

The automatic data record function is used to save the test result data to the internal HDD 
automatically.  This function can be disabled (set to OFF) if the automatic data export function is 
enabled (set to ON).  To set the automatic data record function to OFF, uncheck the Enable 
automatic data record to the internal storage device check box.

For more information, see online help or User’s Guide.
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SMU Calibration Calibration

The Calibration window is opened by clicking the Calibration button. The SMU calibration screen 
of this window is used to perform the calibration of SMUs.  The list area of this screen lists Name, 
Full Range, and Status.

Name: Name of module. To select, check the left check box.

Full Range: For the high resolution SMU (HRSMU) connected to the atto sense/switch unit 
(ASU). Full range calibration on or off.

Status: Calibration status. Pass or fail.

Notes: Error information when calibration failed.

To perform the self-calibration, specify the modules, open the measurement terminals of the 
corresponding modules, and click the Start Calibration button.

Full Range Calibration:
For the HRSMU connected to the ASU. Enables or disables the full range calibration. If this box 
has been unchecked, the B1500 does not use the 1 pA range.

Enable Auto Calibration:
Enables or disables the auto-calibration capability. If this box has been checked (function ON), 
and the B1500 automatically starts calibration for all modules every 30 minutes if the output 
switches of all modules are off for 30 minutes.

NOTE:
To perform calibration correctly, open the measurement terminals.  If auto-calibration is enabled, 
do not forget to open the measurement terminals or disconnect the device under test from the 
terminals after measurement.
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SMU Zero Cancel Calibration

1

2

3

The SMU Zero Cancel screen is used to perform the SMU zero offset current measurement and 
set the SMU zero offset cancel function.

This function subtracts the offset current from the current measurement raw data, and returns 
the result as the measurement data.  This function is used to compensate the error factor (offset 
current) caused by the measurement path such as the measurement cables, manipulators, or 
probe card.

To enable this function, perform the following procedure.

1.Check the left box of the Name column to specify the module to enable this function.

2.Click the Measure… button to perform the zero offset current measurement and wait until the 
measurement is completed.  The measurement data will be displayed in the appropriate cell.

3.Click the Close button to enable the zero offset cancel function.

To disable the function, uncheck the left box of the Name column, and click the Close button.

Note:
The offset cancel is not available for measurement over 100 nA range.  For 10 nA range 
measurement, the offset cancel is performed by using the 1 nA range offset value.  For 
measurement by a range less than 10 nA, the offset value measured by each range is used.

For more information, see online help or User’s Guide.
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CMU Calibration Calibration

The CMU Calibration screen is used to perform the measurement data correction of the multi 
frequency capacitance measurement unit (MFCMU).  For the easy way, perform the phase 
compensation and the open correction at least.  The check boxes left of the Open/Short/Load 
Correction and the Phase Compensation are effective after the corresponding measurement is 
performed.

Measure…: Opens a dialog box used to perform correction/compensation data measurement.  To 
perform the measurement, follow the dialog box.

Advanced Options…: Opens the “Advanced Options for CMU Calibration” dialog box used to set 
the frequencies for the correction data measurement and the reference values of the working 
standard.  See the next page.

To perform the open correction and the phase compensation, open the measurement terminals.

To perform the short correction, connect the measurement terminals together.

To perform the load correction, connect your load standard between the high terminal and the 
low terminal.
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Advanced Options for CMU Calibration Calibration

This dialog box is opened by clicking the Advanced Options... button, and is used to set the 
information required to measure the open/short/load correction data and the phase 
compensation data. This dialog box provides the following action button.

OK: Applies the setup changes and closes this dialog box.

Cancel: Cancel the setup changes and closes this dialog box.

Frequency: You can select the measurement frequency setup mode from the following modes.

Measurement frequency setup modes:

Default (Use factory specified frequencies): Usually, select this mode. Twelve points are 
automatically set. They are 1 k, 2k, 5 k, 10 k, 20 k, 50 k, 100 k, 200 k, 500 k, 1 M, 2 M, and 5 MHz.

Specifies by list: Select this mode when you want to set the frequencies independently. The 
frequency must be 1 kHz to 5 MHz. The number of frequencies must be 1 to 101.  Click Add to 
open a dialog box, and enter the value.  For the unnecessary value, highlight the value and click 
Delete.

Specifies by range: Select this mode when you want to set the frequencies sequentially and 
automatically.  Specify the start frequency, the stop frequency, the number of steps, and the scale 
LINEAR/LOG. The start frequency must be less than the Stop value and at least 1 kHz. The stop 
frequency must be more than the Start value and no more than 5 MHz. The number of steps must 
be 2 to 1001.

NOTE:
If the device measurement frequency is not equal to the correction data measurement frequency, 
calculation will be performed automatically to get the correction data for the device measurement 
frequency, and the calculated correction data will be used for the data correction of the 
measurement data.
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Advanced Options for CMU Calibration Calibration

Integration Time area defines the integration time used for measuring phase compensation data 
or open/short/load correction data.  The number of averaging samples (Mode=AUTO) or the 
averaging time (Mode=PLC) is set.

Mode: A/D converter operation mode, AUTO or PLC.

Factor: Factor for the initial value.  For details, see online help or user’s guide.
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Advanced Options for CMU Calibration Calibration

Reference Standard Values area provides the following entry fields used to set the reference 
values of the open/short/load standard.  If you use the standard, enter the reference values to 
the entry fields.

OPEN Reference: Capacitance and Conductance.  If you do not use the reference, enter 0 in the 
both fields.

SHORT Reference: Inductance and Resistance.  If you do not use the reference, enter 0 in the 
both fields.

LOAD Reference: Inductance and Resistance
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Main Frame Configuration

The Configuration window is opened by clicking the Configuration button, and is used to display 
the system information and event log, as well as to perform diagnostics and self-test.

The Main Frame screen is used to display the system information and perform diagnostics.

Model Identification: Displays the instrument ID. B1500A.

Line Frequency: Sets the power line frequency, 50 Hz or 60 Hz.

EasyEXPERT Rev.: Displays the revision number of the EasyEXPERT.

Firmware Rev.: Displays the revision number of the B1500 firmware.

Main Frame Diagnosis: This area lists Item and Status.

Item: Name of diagnostics item. To select, check the left check box.

Status: Diagnostics status. Pass or fail.

To perform diagnostics, specify the items to perform and click the Start Diagnosis button.  A 
dialog box is opened.  Follow the dialog box to perform the diagnostics.  Some items need your 
judgement, pass or fail.  Also you will need to connect an adapter, press keys, check LEDs, and so 
on.
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Modules Configuration

The Modules screen is used to perform self-test of modules.

Slot: Slot number where the module is installed. To select, check the left check box.

Module Type: Module model number

Name: Module name

Status: Self-test status, Passed, Failed, Recovered, or ---- (self-test has not been performed)

SCUU: Specifies if the module is connected to the SCUU.

Notes: Error information when the module self-test failed.

To perform self-test, specify the modules, open the measurement terminals of the corresponding 
modules, and click the Start Self Test button.

Recover Module button is for the service use only.  This button makes the failed modules respond 
again.  This button does not solve the problem that causes the Failed status.

Status LED: Enables (ON) or disables (OFF) the status indicator (LED) of the ASU (Atto Sense and 
Switch Unit) and the SCUU (SMU CMU Unify Unit).
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Switching Matrix Configuration

The Switching Matrix screen is used to establish the GPIB connection with Agilent 
B2200A/B2201A switching matrix and define the B2200A/B2201A input port connections.

Switching Matrix Type: Displays the type of the switching matrix.  B2200A Femto Leakage Switch 
Mainframe, B2201A 14ch Low Leakage Switch Mainframe, or No Switching Matrix.

GPIB Address: Specifies the GPIB address of the B2200A/B2201A. 1 to 30.

Poll: Confirms if the B2200A/B2201A with the specified GPIB Address is connected to the 
B1500A.

Start Self Test: This button starts the B2200A/B2201A selftest.

SWM IN: SWM IN1 to SWM IN14 mean the B2200A/B2201A input ports 1 to 14 respectively. 
Enter the label used to specify the input port to the right entry field.  The port name and the 
connected module name can be the label. : (colon) cannot be used.

If the Kelvin check box is checked, the coupled even number port is grayed out.

If the CMU check box is checked, the SWM IN14 is grayed out.

Kelvin: Check this box if this port is used for the Kelvin connection.

CMU: To perform capacitance measurement, check this check box and set SWM IN13 to 
CMU1:MF.  And connect MFCMU to B2200A/B2201A Input 13 and 14.  To perform capacitance 
compensation, see User’s Guide.

Extended Configuration: This button opens the Extended Configuration dialog box.
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Extended Configuration Configuration

This dialog box is opened by clicking the Extended Configuration button in the Configuration 
window Switching Matrix screen.

Save as Hardware Profile is used to save the hardware profile that is the B2200A/B2201A 
hardware configuration and the measurement module connection.  Click the Save button to save 
the present hardware profile.  The hardware profile can be made for each workspace individually.

CMU Compensation is used to select the compensation mode of the capacitance measurement 
using the B2200A/B2201A.  Click one of the radio buttons, No Compensation, Select, and User 
Compensation.  For the capacitance compensation, see User’s Guide.

• No Compensation:

Select this radio button if you do not need the capacitance compensation. The raw data without 
compensation is displayed and saved.

• Select:

Select this radio button to perform the capacitance compensation for the path from the 
B2200A/B2201A input ports to Agilent 16495F/G connector plate or Agilent B2220A probe card 
interface. The data after compensation is displayed and saved.

DUT I/F field is used to specify the model number of the path you use.  The selections are the 
16495F/G and B2220A.

Cable field is used to specify the model number of the cable from the B2200A/B2201A output to 
the DUT I/F.  The selections are the 16494A/B/C-001/002/005.  This mode cannot perform the 
capacitance compensation for the cables to positioner/manipulator or the probe card.

• User Compensation Data File:

Select this radio button to perform the capacitance compensation for the path from the 
B2200A/B2201A input ports to the end of positioner/manipulator or probe card.  See User’s 
Guide.  The data after compensation is displayed and saved.
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Event Log Configuration

The Event Log screen displays the event log.

Date/Time: Displays date and time of the event.

Message: Event message

ID: Process ID of the event

Process: Process name

User: User name. Windows login name.

Host: Host name of the B1500

The Refresh button refreshes the event log.
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ASU Configuration

The ASU screen is available if the B1500A installs the HRSMU connected to the ASU (Atto 
Sense/Switch Unit), and shows the ASU information.

Slot: Slot number

Module Type: Type of module

Name: Module name or SMU name

ASU Serial Number: Serial number of the ASU connected to the HRSMU. This cell does not show 
the serial number if no ASU is connected or unpaired ASU is connected.

ASU I/O Path: ASU input to output connection, SMU or AUX

If the ASU I/O Path field is set to SMU, the ASU makes the path from the ASU Force input to the 
ASU output.

If the ASU I/O Path field is set to AUX, the ASU performs automatic switching in every test. The 
ASU makes the path from the AUX In input to the ASU output for the test without the HRSMU 
and makes the path from the ASU Force input to the ASU output for the test with the HRSMU.
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XSLT Samples

-csv.xsl
-tab-sv.xsl
-xmlss.xsl

Right click here

The XSLT sample files are stored in the following folder.  The files can be used as a XML style 
sheet file for exporting test data record.

C:\Program Files\Agilent\B1500A\EasyEXPERT\Utilities\XSLT

csv.xsl:
This file can be used to export test record in the format that uses a comma (,) as data separator.

This file is used to realize the Export As CSV... function. 

tab-sv.xsl:
This file can be specified in the XML Style Sheet File Path field in the Export Using XSLT dialog 
box if you want to export a test record in the format that uses a tab as data separator. 

xmlss.xsl:
This file can be used to export test record in the XML Spread Sheet format.  This file is used to 
realize the Export As XML Spread Sheet... function.
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To Enable System Controller
Agilent IO Library Connection Expert

To control external GPIB devices, the B1500A must be set to system controller.  Exit the EasyEXPERT, and 
close the Start EasyEXPERT window.  After that, launch the Agilent Connection Expert by clicking Start, All 
Programs, Agilent IO Library Suite, and Agilent connection Expert.

On the Agilent Connection Expert, change the GPIB configuration of the B1500A.

•Select GPIB0.

•Click Change Properties… button.

•Change GPIB address to 21 that is the typical address number for the system controller.

•Check System controller box.

•Click OK button.

•Reboot the B1500A.
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To Start Desktop EasyEXPERT

To open the Start EasyEXPERT window, click Start > Programs > Start EasyEXPERT menu.  The 
Option menu provides the functions used to open the following dialog box.

Gpib Configuration:
Select Online if the B1500A is connected to your computer and you want to control the B1500A 
via GPIB.  Or select Offline.

EasyEXPERT Database:
Specify the EasyEXPERT Database path if you want to move the database to the other folder.

After that, click the Start EasyEXPERT button to launch Desktop EasyEXPERT.

Note:
Desktop EasyEXPERT supports most B1500A/EasyEXPERT functions.  However, some functions 
are not supported on an external computers due to differences in hardware and so on.

Note:
For the installation procedure, see the readme file stored in the Desktop EasyEXPERT CD-ROM.
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To Use Setup File Converter

To convert the 4155/4156 setup file (.MES file) to the EasyEXPERT setup file (.XTS file), use 
SetupFileConverter.exe, and perform the following procedure.  The SetupFileConverter.exe file is 
stored in the following folder.

C:\Program Files\Agilent\B1500A\EasyEXPERT\Utilities

1.Create your working folder (for example, C:\415xdata).

2.Copy your .MES files to this folder.

3.Copy SetupFileConverter.exe file to this folder.

4.Launch the DOS Prompt window.

5.Go to your working folder (for example, C:\> cd 415xdata).

6.Execute SetupFileConverter.exe as shown below.

Example:
C:\415xdata> SetupFileConverter.exe *.MES

All .MES files in your working folder will be converted to the EasyEXPERT setup file format.  And 
the .XTS files will be created in this folder.

If you do not specify the parameter, help message will be displayed by executing the file.  For 
more information, see the setup converter readme file, online help, or User’s Guide.
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